summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@gentoo.org>2024-07-21 22:51:02 +0200
committerPetr Vaněk <arkamar@gentoo.org>2024-07-21 23:02:10 +0200
commit56e5e1c7dc8b240798ebd74a65f1f2199ceba43f (patch)
tree072b459f854dd631f1844265f6263f144f05f6d3 /dev-util/howdoi
parentdev-lang/nim: Stabilize 2.0.6 amd64, #936462 (diff)
downloadgentoo-56e5e1c7dc8b240798ebd74a65f1f2199ceba43f.tar.gz
gentoo-56e5e1c7dc8b240798ebd74a65f1f2199ceba43f.tar.bz2
gentoo-56e5e1c7dc8b240798ebd74a65f1f2199ceba43f.zip
dev-util/howdoi: wire up tests, enable py3.12
It was necessary to switch to GH sources, because pypi sources do not contain test data files. Signed-off-by: Petr Vaněk <arkamar@gentoo.org>
Diffstat (limited to 'dev-util/howdoi')
-rw-r--r--dev-util/howdoi/Manifest1
-rw-r--r--dev-util/howdoi/howdoi-2.0.20-r2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-util/howdoi/Manifest b/dev-util/howdoi/Manifest
index 4d2a272823fa..18b143f585b5 100644
--- a/dev-util/howdoi/Manifest
+++ b/dev-util/howdoi/Manifest
@@ -1,2 +1,3 @@
DIST howdoi-2.0.19.tar.gz 27109 BLAKE2B 32c7ebf177a5a51f9df924440c5767e1a47125e24b821b51b28cfec45a747f7c04265b93aa0a68a85d2f65582617f866483aa77e8c1168903ef9dfdc860535f5 SHA512 e3e074f7b122513486bda0a0f68d31d51a2da2f17efe5c6ae2b5c49f44dd0f80a735d67a33e3d47eea51d83968da19bc294fc74a30f7e30457058ad9919e105a
+DIST howdoi-2.0.20.gh.tar.gz 2516362 BLAKE2B 4b871661e4926ecfc1eadb095301a5c69fb70d80c1d7ca5aa4c2a6fad36a2bfb53469a79da89b1e28a659cdf0493a7ab47b231e391167c80010303684835bc0f SHA512 1efa479a92b85e418ee83e0f25e00fdc276f0ccb504af924106f925b80ce39af2c92a2dc27744e4816d67e764783f98771eb3ea889c08953e0bade17553f12fe
DIST howdoi-2.0.20.tar.gz 27595 BLAKE2B 30644384dbe4c6073bd380a283f2af38943822480eebecbdfb252ca225c31579905bf023a90ba907be27e59ec4ae422f27accbe33d30340075264264e865d8b7 SHA512 0950a9f2366817646741c554a0f4b7bd1f05f614af9460ccb110dc0d0f68f58dd6437fedb237df4b340b5a4fbc569faf315273937f6520a85060791044b3dadf
diff --git a/dev-util/howdoi/howdoi-2.0.20-r2.ebuild b/dev-util/howdoi/howdoi-2.0.20-r2.ebuild
new file mode 100644
index 000000000000..a733522563e3
--- /dev/null
+++ b/dev-util/howdoi/howdoi-2.0.20-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517="setuptools"
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1
+
+DESCRIPTION="A code search tool"
+HOMEPAGE="https://pypi.org/project/howdoi/"
+# pypi sources do not contain test data
+SRC_URI="
+ https://github.com/gleitz/howdoi/archive/refs/tags/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/appdirs[${PYTHON_USEDEP}]
+ dev-python/cachelib[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/keep[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ >=dev-python/pyquery-1.4.1[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.24.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+
+src_test() {
+ # following varaible disables colorization test, which does not work on non-tty output
+ # see https://github.com/gleitz/howdoi/commit/c53b6a179a09159740de2c06fb87b194e810f839
+ local -x GITHUB_ACTION=1
+ distutils-r1_src_test
+}