summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-05-10 08:59:08 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-05-10 10:01:09 +0200
commit68decc065ca312b10e9af2c7fb3d682bfc740d67 (patch)
tree596eb51dc00331781fa9221730a4b54978ca324f /dev-util/kdevelop-python
parentapp-office/libreoffice-l10n: 6.0.4.2 version bump (diff)
downloadgentoo-68decc065ca312b10e9af2c7fb3d682bfc740d67.tar.gz
gentoo-68decc065ca312b10e9af2c7fb3d682bfc740d67.tar.bz2
gentoo-68decc065ca312b10e9af2c7fb3d682bfc740d67.zip
dev-util/kdevelop-python: Fix build with Qt 5.11
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Diffstat (limited to 'dev-util/kdevelop-python')
-rw-r--r--dev-util/kdevelop-python/files/kdevelop-python-5.2.1-qt-5.11.patch24
-rw-r--r--dev-util/kdevelop-python/kdevelop-python-5.2.1.ebuild2
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/kdevelop-python/files/kdevelop-python-5.2.1-qt-5.11.patch b/dev-util/kdevelop-python/files/kdevelop-python-5.2.1-qt-5.11.patch
new file mode 100644
index 000000000000..67528c558504
--- /dev/null
+++ b/dev-util/kdevelop-python/files/kdevelop-python-5.2.1-qt-5.11.patch
@@ -0,0 +1,24 @@
+From a4a3cfb040054e7ca938bdd593c6c3c80d80807f Mon Sep 17 00:00:00 2001
+From: Luca Beltrame <lbeltrame@kde.org>
+Date: Thu, 10 May 2018 06:55:07 +0200
+Subject: Fix build with Qt 5.11
+
+Some includes were added transitively, now they need to be explicit.
+---
+ codegen/correctionfilegenerator.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/codegen/correctionfilegenerator.cpp b/codegen/correctionfilegenerator.cpp
+index bb79a25..53ebec4 100644
+--- a/codegen/correctionfilegenerator.cpp
++++ b/codegen/correctionfilegenerator.cpp
+@@ -20,6 +20,7 @@
+
+ #include "correctionfilegenerator.h"
+
++#include <QAction>
+ #include <QTemporaryFile>
+
+ #include <language/backgroundparser/backgroundparser.h>
+--
+cgit v0.11.2
diff --git a/dev-util/kdevelop-python/kdevelop-python-5.2.1.ebuild b/dev-util/kdevelop-python/kdevelop-python-5.2.1.ebuild
index ba7fd2bc14f1..11bbd220000a 100644
--- a/dev-util/kdevelop-python/kdevelop-python-5.2.1.ebuild
+++ b/dev-util/kdevelop-python/kdevelop-python-5.2.1.ebuild
@@ -39,6 +39,8 @@ RDEPEND="${DEPEND}
RESTRICT+=" test"
+PATCHES=( "${FILESDIR}/${P}-qt-5.11.patch" )
+
pkg_setup() {
python-single-r1_pkg_setup
kde5_pkg_setup