summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2023-06-21 10:02:45 +0300
committerJoonas Niilola <juippis@gentoo.org>2023-06-21 10:02:45 +0300
commit55fd3cd13333e2910b3eb121211d0a3816b269ec (patch)
treeb2a297cee1066826f65e86983bda463cc79f0cf5 /dev-util/librnp
parentdev-util/librnp: adjust dev-libs/sexp dependency (diff)
downloadgentoo-55fd3cd13333e2910b3eb121211d0a3816b269ec.tar.gz
gentoo-55fd3cd13333e2910b3eb121211d0a3816b269ec.tar.bz2
gentoo-55fd3cd13333e2910b3eb121211d0a3816b269ec.zip
dev-util/librnp: drop 0.16.3
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util/librnp')
-rw-r--r--dev-util/librnp/Manifest1
-rw-r--r--dev-util/librnp/librnp-0.16.3.ebuild73
2 files changed, 0 insertions, 74 deletions
diff --git a/dev-util/librnp/Manifest b/dev-util/librnp/Manifest
index 4205de3c1ee2..1fbb672e9a3f 100644
--- a/dev-util/librnp/Manifest
+++ b/dev-util/librnp/Manifest
@@ -1,2 +1 @@
-DIST librnp-0.16.3.tar.gz 2897854 BLAKE2B 71e39e810bdbee351c8136df1d11621daccb1738db691b99244ffe5bd2ea372c3ef520ade7cd63c38510fae0f252d5a1c2ceb44db3fbffbd64dfc10612341e29 SHA512 b133fb1f9aab6e9b5caecdcf0bd9f2c67a62a98543ca1ac6a7cf4a35b7a571d53e4fa99cefc98f8253117cf0de16194db309efa03bc40fd3556f9b84cf51a942
DIST librnp-0.17.0.tar.gz 2996461 BLAKE2B 9a6ea0452f067464ef52cef395c2969ba9912c5ed32ac6f4d860a3410965dbfbb1ad5c0d4f25489011d869222a4362a90463f521efe5af4b7c412f0ed1e4570b SHA512 0aa5262aa3be163b8a8931d6b9200ced52bb640cd7b02b50009cfb8d5fe1e664d27b2c4a0a3e534cf59d6ea42fbc1c62c970a07cadc27ab6962e0f69f996f74d
diff --git a/dev-util/librnp/librnp-0.16.3.ebuild b/dev-util/librnp/librnp-0.16.3.ebuild
deleted file mode 100644
index 92d66a7681ba..000000000000
--- a/dev-util/librnp/librnp-0.16.3.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit cmake
-
-DESCRIPTION="High performance C++ OpenPGP library"
-HOMEPAGE="https://www.rnpgp.org/ https://github.com/rnpgp/rnp"
-SRC_URI="https://github.com/rnpgp/rnp/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0 BSD BSD-2"
-SLOT="0/0.16.1"
-KEYWORDS="amd64 ~arm64 ~ppc64 x86"
-IUSE="+botan man test"
-
-RDEPEND="app-arch/bzip2
- dev-libs/json-c:=
- sys-libs/zlib
- botan? ( dev-libs/botan:2= )
- !botan? ( >=dev-libs/openssl-1.1.1:= )"
-DEPEND="${RDEPEND}
- test? ( dev-cpp/gtest )"
-BDEPEND="man? ( dev-ruby/asciidoctor )"
-
-RESTRICT="!test? ( test )"
-S="${WORKDIR}/${P/*lib/}"
-
-src_configure() {
- local mycmakeargs=(
- -DBUILD_TESTING=$(usex test on off)
-
- -DCRYPTO_BACKEND=$(usex botan botan openssl)
-
- -DDOWNLOAD_GTEST=off
- -DDOWNLOAD_RUBYRNP=off
-
- -DENABLE_COVERAGE=off
- -DENABLE_DOC=$(usex man on off)
- -DENABLE_FUZZERS=off
- -DENABLE_SANITIZERS=off
- )
-
- if use botan; then
- local mycmakeargs+=(
- -DENABLE_AEAD=on
- -DENABLE_BRAINPOOL=on
- -DENABLE_IDEA=on
- -DENABLE_SM2=on
- -DENABLE_TWOFISH=on
- )
-
- # OpenSSL support is still not as complete as botan.
- # https://github.com/rnpgp/rnp/issues/1642 (v. 0.17.0),
- # https://github.com/rnpgp/rnp/issues/1877 SM2,
- # https://github.com/openssl/openssl/issues/2046 TWOFISH (won't be implemented).
- else
- local mycmakeargs+=(
- -DENABLE_AEAD=off
- -DENABLE_BRAINPOOL=on
- -DENABLE_IDEA=on
- -DENABLE_SM2=off
- -DENABLE_TWOFISH=off
- )
- fi
-
- cmake_src_configure
-}
-
-src_test() {
- cd "${BUILD_DIR}"/src/tests || die
- ctest -j"${MAKEOPTS}" -R .* --output-on-failure || die
-}