summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-util/patchutils
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-util/patchutils')
-rw-r--r--dev-util/patchutils/Manifest1
-rw-r--r--dev-util/patchutils/files/patchutils-0.3.3-format-security.patch25
-rw-r--r--dev-util/patchutils/metadata.xml8
-rw-r--r--dev-util/patchutils/patchutils-0.3.3.ebuild25
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-util/patchutils/Manifest b/dev-util/patchutils/Manifest
new file mode 100644
index 000000000000..90d9829a68a4
--- /dev/null
+++ b/dev-util/patchutils/Manifest
@@ -0,0 +1 @@
+DIST patchutils-0.3.3.tar.xz 156328 SHA256 91f4e8451b2efcac5d40c966e42c175803450f0de94c926bfecc12c90070ad3c SHA512 4ec085078e9ae2e878dc10fbfea5974d9772716aef5d8e130a0023ceaa26640bccfaf1022c8153923b38230b36c8d4dddf4aaa674076c733bb1277895b63a268 WHIRLPOOL b4db67f2682e3bd4a37abacaa56477f7bfe79210469243c572ebd870e0e19cb54e51d6be79b737210e9de685d09470ce2d2db0452fe4b8f26f72f06a9cb6b3f8
diff --git a/dev-util/patchutils/files/patchutils-0.3.3-format-security.patch b/dev-util/patchutils/files/patchutils-0.3.3-format-security.patch
new file mode 100644
index 000000000000..be190b65a734
--- /dev/null
+++ b/dev-util/patchutils/files/patchutils-0.3.3-format-security.patch
@@ -0,0 +1,25 @@
+ src/filterdiff.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/filterdiff.c b/src/filterdiff.c
+index eb08d49..0b2b301 100644
+--- a/src/filterdiff.c
++++ b/src/filterdiff.c
+@@ -1263,7 +1263,7 @@ read_regex_file (const char *file)
+ char errstr[300];
+ regerror (err, &regex[num_regex - 1], errstr,
+ sizeof (errstr));
+- error (EXIT_FAILURE, 0, errstr);
++ error (EXIT_FAILURE, 0, "%s", errstr);
+ exit (1);
+ }
+ }
+@@ -1509,7 +1509,7 @@ int main (int argc, char *argv[])
+ char errstr[300];
+ regerror (err, &regex[num_regex - 1], errstr,
+ sizeof (errstr));
+- error (EXIT_FAILURE, 0, errstr);
++ error (EXIT_FAILURE, 0, "%s", errstr);
+ exit (1);
+ }
+ }
diff --git a/dev-util/patchutils/metadata.xml b/dev-util/patchutils/metadata.xml
new file mode 100644
index 000000000000..934d5c44fc6f
--- /dev/null
+++ b/dev-util/patchutils/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>flameeyes@gentoo.org</email>
+ </maintainer>
+ <herd>shell-tools</herd>
+</pkgmetadata>
diff --git a/dev-util/patchutils/patchutils-0.3.3.ebuild b/dev-util/patchutils/patchutils-0.3.3.ebuild
new file mode 100644
index 000000000000..36a18d6d968b
--- /dev/null
+++ b/dev-util/patchutils/patchutils-0.3.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="A collection of tools that operate on patch files"
+HOMEPAGE="http://cyberelk.net/tim/patchutils/"
+SRC_URI="http://cyberelk.net/tim/data/patchutils/stable/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~ppc-aix ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE="test"
+
+RDEPEND=""
+# The testsuite makes use of gendiff(1) that comes from rpm, thus if
+# the user wants to run tests, it should install that too.
+DEPEND="test? ( app-arch/rpm )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-format-security.patch
+}