summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-07-20 19:49:12 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-07-20 20:16:54 +0100
commitcdd070db799dfc80b7685759ad74bb2c9e5a0de3 (patch)
tree42d31a7a457a7ec0236be7958314d81ee6da01fd /dev-util/re2c
parentmedia-gfx/pngquant: amd64 stable (bug #718926) (diff)
downloadgentoo-cdd070db799dfc80b7685759ad74bb2c9e5a0de3.tar.gz
gentoo-cdd070db799dfc80b7685759ad74bb2c9e5a0de3.tar.bz2
gentoo-cdd070db799dfc80b7685759ad74bb2c9e5a0de3.zip
dev-util/re2c: bump up to 2.0
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util/re2c')
-rw-r--r--dev-util/re2c/Manifest1
-rw-r--r--dev-util/re2c/re2c-2.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/re2c/Manifest b/dev-util/re2c/Manifest
index 673e571559e6..ddb0e13d0d69 100644
--- a/dev-util/re2c/Manifest
+++ b/dev-util/re2c/Manifest
@@ -1 +1,2 @@
DIST re2c-1.3.tar.xz 1239280 BLAKE2B ae2a8fc323408dd31d39c352bd622d89d19178b7993618ea043bbfd32509fb7573d2b5b50663e100d24fc275fa479982cb1f66ed49638edca61f551fb653176d SHA512 c7084ab2399fb6b96cef74c1393715d90830f43b82b96af46feb71ef008c0215381c3dbea0b003ff810d869db6021e28001b9d588ad55c616642244b2da09c0e
+DIST re2c-2.0.tar.xz 1282268 BLAKE2B c8a143f5e15e90874f5f6848302b34e0047451cd0ff7c082a80774f1bfd5ca088bef62da17e56f17692a86c5b3643c19035b052a7ed0a94ba6740957f50b4257 SHA512 0688c810c47b5e219b73e7ffe534a3933419d585f7cb2a3ca40d069e49b574a6d17ca4fc5e45403d0f03f1da39c89cbed8c7d8e1e3f9a836d83e3d5ad59a11e2
diff --git a/dev-util/re2c/re2c-2.0.ebuild b/dev-util/re2c/re2c-2.0.ebuild
new file mode 100644
index 000000000000..082465fa4c7b
--- /dev/null
+++ b/dev-util/re2c/re2c-2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="tool for generating C-based recognizers from regular expressions"
+HOMEPAGE="http://re2c.org/"
+SRC_URI="https://github.com/skvadrik/re2c/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
+IUSE="debug"
+
+src_configure() {
+ econf \
+ --enable-golang \
+ ac_cv_path_BISON="no" \
+ $(use_enable debug)
+}
+
+src_install() {
+ default
+
+ docompress -x /usr/share/doc/${PF}/examples
+ dodoc -r README.md CHANGELOG examples
+}