summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-04-29 21:40:38 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-04-29 21:41:01 +0200
commit05f98b2284e04f5078b8b38238d6688f9c76414b (patch)
tree4e89d123ab55d37a295f82c1b793c2edeedc5407 /dev-util/samurai
parentgames-misc/openmsx: Drop old (diff)
downloadgentoo-05f98b2284e04f5078b8b38238d6688f9c76414b.tar.gz
gentoo-05f98b2284e04f5078b8b38238d6688f9c76414b.tar.bz2
gentoo-05f98b2284e04f5078b8b38238d6688f9c76414b.zip
dev-util/samurai: Security revbump to fix mull pointer dereference
Removed old Bug: https://bugs.gentoo.org/786957 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'dev-util/samurai')
-rw-r--r--dev-util/samurai/files/samurai-1.2-null_pointer_fix.patch26
-rw-r--r--dev-util/samurai/samurai-1.2-r1.ebuild (renamed from dev-util/samurai/samurai-1.2.ebuild)4
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/samurai/files/samurai-1.2-null_pointer_fix.patch b/dev-util/samurai/files/samurai-1.2-null_pointer_fix.patch
new file mode 100644
index 000000000000..fbc97b03d478
--- /dev/null
+++ b/dev-util/samurai/files/samurai-1.2-null_pointer_fix.patch
@@ -0,0 +1,26 @@
+From d2af3bc375e2a77139c3a28d6128c60cd8d08655 Mon Sep 17 00:00:00 2001
+From: Michael Forney <mforney@mforney.org>
+Date: Sun, 4 Apr 2021 03:50:09 -0700
+Subject: [PATCH] parse: Check for non-empty command/rspfile/rspfile_content
+
+This matches ninja behavior and prevents the possibility of a rule
+with an empty (NULL) command string.
+
+Fixes #68.
+---
+ parse.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/parse.c b/parse.c
+index f79a5ee..b4b98a1 100644
+--- a/parse.c
++++ b/parse.c
+@@ -42,6 +42,8 @@ parserule(struct scanner *s, struct environment *env)
+ var = scanname(s);
+ parselet(s, &val);
+ ruleaddvar(r, var, val);
++ if (!val)
++ continue;
+ if (strcmp(var, "command") == 0)
+ hascommand = true;
+ else if (strcmp(var, "rspfile") == 0)
diff --git a/dev-util/samurai/samurai-1.2.ebuild b/dev-util/samurai/samurai-1.2-r1.ebuild
index 4333d1997bfa..ad8d964b12b3 100644
--- a/dev-util/samurai/samurai-1.2.ebuild
+++ b/dev-util/samurai/samurai-1.2-r1.ebuild
@@ -16,6 +16,10 @@ fi
LICENSE="ISC Apache-2.0 MIT"
SLOT="0"
+PATCHES=(
+ "${FILESDIR}/${P}-null_pointer_fix.patch" #786957
+)
+
src_install() {
emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
dodoc README.md