summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortoshokan <toshokan@shojigate.net>2021-08-23 23:39:51 -0400
committerJoonas Niilola <juippis@gentoo.org>2021-08-26 13:51:34 +0300
commitf2123c47a7f5789c28e5294249e31db2c5fb759a (patch)
tree51360f83673b2bb56b3cdce29d25b0a62dc0e901 /dev-util/shards/shards-0.15.0-r1.ebuild
parentdev-lang/crystal: bump to 1.1.1, new maintainer (diff)
downloadgentoo-f2123c47a7f5789c28e5294249e31db2c5fb759a.tar.gz
gentoo-f2123c47a7f5789c28e5294249e31db2c5fb759a.tar.bz2
gentoo-f2123c47a7f5789c28e5294249e31db2c5fb759a.zip
dev-util/shards: Depend on libyaml, drop old
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Jason Pizzuco <toshokan@shojigate.net> Closes: https://github.com/gentoo/gentoo/pull/21848 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util/shards/shards-0.15.0-r1.ebuild')
-rw-r--r--dev-util/shards/shards-0.15.0-r1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-util/shards/shards-0.15.0-r1.ebuild b/dev-util/shards/shards-0.15.0-r1.ebuild
new file mode 100644
index 000000000000..cd40186df456
--- /dev/null
+++ b/dev-util/shards/shards-0.15.0-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multiprocessing toolchain-funcs
+
+CRYSTAL_MOLINILLO_PV=0.2.0
+CRYSTAL_MOLINILLO_P=crystal-molinillo-${CRYSTAL_MOLINILLO_PV}
+
+DESCRIPTION="Dependency manager for the Crystal language"
+HOMEPAGE="https://github.com/crystal-lang/shards"
+SRC_URI="
+ https://github.com/crystal-lang/shards/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/crystal-lang/crystal-molinillo/archive/v${CRYSTAL_MOLINILLO_PV}.tar.gz -> ${CRYSTAL_MOLINILLO_P}.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >dev-lang/crystal-0.11.1
+ dev-libs/libyaml
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT=test # missing files in tarball
+
+src_prepare() {
+ default
+
+ # bundle crystal-molinillo to bootstrap 'shards'
+ mkdir -p lib || die
+ ln -s ../../${CRYSTAL_MOLINILLO_P} lib/molinillo || die
+
+ tc-export CC
+}
+
+src_compile() {
+ emake release=1 FLAGS="--link-flags=\"${LDFLAGS}\" --verbose --threads $(makeopts_jobs)"
+}
+
+src_install() {
+ dobin bin/${PN}
+ dodoc README.md
+}