summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2020-05-23 11:12:57 +0100
committerSergei Trofimovich <slyfox@gentoo.org>2020-05-23 11:13:09 +0100
commit4268e63a833c6a64434602710ee8a91aa0036d3e (patch)
tree90e516a6d3c4b3ac0fb9d5bde0ccfacb45d85b33 /dev-util/shards
parentx11-themes/greybird: Migrate to 'appindicator' USE (diff)
downloadgentoo-4268e63a833c6a64434602710ee8a91aa0036d3e.tar.gz
gentoo-4268e63a833c6a64434602710ee8a91aa0036d3e.tar.bz2
gentoo-4268e63a833c6a64434602710ee8a91aa0036d3e.zip
dev-util/shards: bump up to 0.10.0
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
Diffstat (limited to 'dev-util/shards')
-rw-r--r--dev-util/shards/Manifest2
-rw-r--r--dev-util/shards/shards-0.10.0.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-util/shards/Manifest b/dev-util/shards/Manifest
index 91732a057bf1..8ea095c9a1c1 100644
--- a/dev-util/shards/Manifest
+++ b/dev-util/shards/Manifest
@@ -1 +1,3 @@
+DIST crystal-molinillo-0.1.0.tar.gz 23932 BLAKE2B c9bcd707a3208f5d80e6e3030523d50f86cb5977799de8ea6035d014094e3c2fff9bb189fa98f566e72e1e7ad161e47e44c89d9b264d47f109b2e891ecb469e5 SHA512 8d74d95896cd7ff510c87e2ffba6ae5f04ceeddde574930ee609851312b65d713a315cc24f9aa3fab02f9447ccb25ef2dd2e8179640b8c5cfb3d7d6b52d1ded5
+DIST shards-0.10.0.tar.gz 39507 BLAKE2B f6b6034a626500d0459e01be73de28506dc2efe116a5f662b27edb6cbe363cf4bb3184fcce83838e02dec4db18355a85737b4783560b7d94b643145d08581174 SHA512 8d41a2553fd99bd44a3e8a9aacbd17f2a1e9f8730f90c4682091e8d2a4f2388818bdfc4e4bf654c3cbebd617a74474fb63f1fb86a62998cf79409d4778649757
DIST shards-0.9.0.tar.gz 41280 BLAKE2B a74ab96489c804da3017dc683295d1fc16ba30248015af9deccdcf52a09301f665d4848822419d263d2301969c484fae288eff63e281bd4841b1fd101c5d5383 SHA512 a06579f1a96cea1fb1ba97c17ae4529439fb7c54572e74b4969921b1a987a1e1be9c9eb8569db94fd4cb4adc098b3085abfd2a6f7015da7f39611a1774d30022
diff --git a/dev-util/shards/shards-0.10.0.ebuild b/dev-util/shards/shards-0.10.0.ebuild
new file mode 100644
index 000000000000..c36571a58c8e
--- /dev/null
+++ b/dev-util/shards/shards-0.10.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+CRYSTAL_MOLINILLO_PV=0.1.0
+CRYSTAL_MOLINILLO_P=crystal-molinillo-${CRYSTAL_MOLINILLO_PV}
+
+DESCRIPTION="Dependency manager for the Crystal language"
+HOMEPAGE="https://github.com/crystal-lang/shards"
+SRC_URI="
+ https://github.com/crystal-lang/shards/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/crystal-lang/crystal-molinillo/archive/v${CRYSTAL_MOLINILLO_PV}.tar.gz -> ${CRYSTAL_MOLINILLO_P}.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ >dev-lang/crystal-0.11.1[yaml]
+"
+RDEPEND="${DEPEND}"
+
+RESTRICT=test # missing files in tarball
+
+src_prepare() {
+ default
+
+ # bundle crystal-molinillo to bootstrap 'shards'
+ mkdir -p lib || die
+ ln -s ../../${CRYSTAL_MOLINILLO_P} lib/molinillo || die
+
+ tc-export CC
+}
+
+src_install() {
+ dobin bin/${PN}
+ dodoc README.md
+}