summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-10-08 20:43:39 +0200
committerDavid Seifert <soap@gentoo.org>2016-10-08 20:44:27 +0200
commita20f82824bff15ec83702f07697f3b2433a17e5c (patch)
tree25b91a90b36f1ee2d94247ea8577ca2aaec51a83 /dev-util/source-highlight
parentx11-libs/gtk+: version bump from 2.24.31 to 2.24.31-r1 (diff)
downloadgentoo-a20f82824bff15ec83702f07697f3b2433a17e5c.tar.gz
gentoo-a20f82824bff15ec83702f07697f3b2433a17e5c.tar.bz2
gentoo-a20f82824bff15ec83702f07697f3b2433a17e5c.zip
dev-util/source-highlight: Version bump to 3.1.8
Gentoo-bug: 507112, 579002, 582694, 582696 * EAPI=6 * Build using C++14 mode (due to boost-1.62) Package-Manager: portage-2.3.1
Diffstat (limited to 'dev-util/source-highlight')
-rw-r--r--dev-util/source-highlight/Manifest1
-rw-r--r--dev-util/source-highlight/source-highlight-3.1.8.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-util/source-highlight/Manifest b/dev-util/source-highlight/Manifest
index 1442cf946c12..c48c2ebfc738 100644
--- a/dev-util/source-highlight/Manifest
+++ b/dev-util/source-highlight/Manifest
@@ -1 +1,2 @@
DIST source-highlight-3.1.7.tar.gz 1600692 SHA256 e1b2e007cdd94595393d42510e2a84763c36aad3409f0c3087f05fcb50a389e8 SHA512 4a1e733bd06468e6ebd023dfe4a62d7134c35aac311509a61e8d80de35ff3cea25fb79adb56bfe413ee214bbf4d578b4d4ebdcf1236481d9b83152aff6d7afb8 WHIRLPOOL 3d99a135abef73e865d2729bcbdf47fc7c143aeef91015b73a87d4a129323ca95aac153c3fa7d5207afb2a03ecba2f05db3e3ed8627b1e0477dcd9dfa830bbb7
+DIST source-highlight-3.1.8.tar.gz 1648351 SHA256 01336a7ea1d1ccc374201f7b81ffa94d0aecb33afc7d6903ebf9fbf33a55ada3 SHA512 00a49ab180460750614b38be9a569478d1d34d01f601ebc7452a4fee8475a19faf9bb9fb2f256c6b40d43fbc3d34962a77ba8b9833483345c4e4a42faad6976c WHIRLPOOL a05c3028816d0e0f0236ed18b806ce7f9f8f82be61b142774fe2156543c577bfcd5fb49bb259f03b4e97d5c01b5292e3b82720e29ccafa3a6bd7661f353ade5d
diff --git a/dev-util/source-highlight/source-highlight-3.1.8.ebuild b/dev-util/source-highlight/source-highlight-3.1.8.ebuild
new file mode 100644
index 000000000000..99bb2f47a670
--- /dev/null
+++ b/dev-util/source-highlight/source-highlight-3.1.8.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit bash-completion-r1 flag-o-matic
+
+DESCRIPTION="Generate highlighted source code as an (x)html document"
+HOMEPAGE="https://www.gnu.org/software/src-highlite/source-highlight.html"
+SRC_URI="mirror://gnu/src-highlite/${P}.tar.gz"
+LICENSE="GPL-3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+SLOT="0"
+IUSE="doc static-libs"
+
+RDEPEND=">=dev-libs/boost-1.62.0:=[threads]
+ dev-util/ctags"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ # required as rev-dep of dev-libs/boost-1.62.0
+ # https://wiki.gentoo.org/wiki/Project:C%2B%2B/Maintaining_ABI
+ append-cxxflags -std=c++14
+
+ econf \
+ --with-boost-regex="boost_regex" \
+ --without-bash-completion \
+ $(use_enable static-libs static)
+}
+
+src_install () {
+ use doc && local HTML_DOCS=( doc/*.{html,css,java} )
+ default
+
+ # That's not how we want it
+ rm -rf "${ED%/}"/usr/share/{aclocal,doc} || die
+
+ # package provides .pc file
+ find "${D}" -name '*.la' -delete || die
+
+ dobashcomp completion/source-highlight
+}
+
+src_test() {
+ export LD_LIBRARY_PATH="${S}/lib/srchilite/.libs/"
+ default
+}