summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-13 11:21:02 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-13 15:14:06 +0200
commit22639ea05828e00eea1d585e2cf3f7177ba943b8 (patch)
tree3aa96d904c7e02d7dcbba0bceea6094fae3f2df2 /dev-util/squashdelta
parentpackage.mask: unmask net-libs/nDPI and friends (diff)
downloadgentoo-22639ea05828e00eea1d585e2cf3f7177ba943b8.tar.gz
gentoo-22639ea05828e00eea1d585e2cf3f7177ba943b8.tar.bz2
gentoo-22639ea05828e00eea1d585e2cf3f7177ba943b8.zip
dev-util/squashdelta: Bump to 0.1.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-util/squashdelta')
-rw-r--r--dev-util/squashdelta/Manifest1
-rw-r--r--dev-util/squashdelta/squashdelta-0.1.2.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/squashdelta/Manifest b/dev-util/squashdelta/Manifest
index 2eff03e62875..0cdba9408f90 100644
--- a/dev-util/squashdelta/Manifest
+++ b/dev-util/squashdelta/Manifest
@@ -1 +1,2 @@
DIST squashdelta-0.1.1.tar.bz2 78504 BLAKE2B f9aa13b3af35bd97650b31fac718837763b73c2817548a3fde75841993092d717ea78826a3e29d472290d4f9164f8cfcc9f9999613f199c21251080584dbd9f7 SHA512 efe90831e412ed6627d44390054dc89339e85bcd3be452f16fb32d00989bbdc9480dbefcea624941b4866a686a356b0371c33de31903afa70af26eecbe902844
+DIST squashdelta-0.1.2.tar.bz2 79865 BLAKE2B fe375da70e25eaa5b70aa2e231f04b9ce47aa1aaea3872df331065ba8710a0e4ce1ca096715d18e5094f514ce3a8adb9d08109a4894ca75a4b3e5ef083f8e66f SHA512 802a1a6c6e7d117e4fb7f74a8144cc7b8b237e28f2028c72623b99a88b23d857ceb99f2d23653d253af829c3e6b290db98420923d613569cf523c2a7fc600f43
diff --git a/dev-util/squashdelta/squashdelta-0.1.2.ebuild b/dev-util/squashdelta/squashdelta-0.1.2.ebuild
new file mode 100644
index 000000000000..3b8ffebd419f
--- /dev/null
+++ b/dev-util/squashdelta/squashdelta-0.1.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Efficient (partially uncompressed) SquashFS binary delta tool"
+HOMEPAGE="https://github.com/mgorny/squashdelta/"
+SRC_URI="https://github.com/mgorny/squashdelta/releases/download/v${PV}/${P}.tar.bz2"
+
+# uses public-domain murmurhash3
+LICENSE="BSD public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="lz4 +lzo"
+# SquashDelta does not make much sense without a compression algo.
+REQUIRED_USE="|| ( lz4 lzo )"
+
+COMMON_DEPEND="
+ lz4? ( app-arch/lz4:0= )
+ lzo? ( dev-libs/lzo:2= )"
+RDEPEND="${COMMON_DEPEND}
+ dev-util/xdelta:3"
+DEPEND=${COMMON_DEPEND}
+
+src_configure() {
+ local myconf=(
+ $(use_enable lz4)
+ $(use_enable lzo)
+ )
+
+ econf "${myconf[@]}"
+}