summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2023-11-07 00:51:53 +0100
committerSebastian Pipping <sping@gentoo.org>2023-11-07 00:51:53 +0100
commit95a0ae22cca97bd030abbfc59e7007195c6415de (patch)
tree81a50ceb47f18c469a5d4e941c40555c7c6b3ea3 /dev-util/ydiff
parentdev-util/gprof2dot: Python 3.12 (diff)
downloadgentoo-95a0ae22cca97bd030abbfc59e7007195c6415de.tar.gz
gentoo-95a0ae22cca97bd030abbfc59e7007195c6415de.tar.bz2
gentoo-95a0ae22cca97bd030abbfc59e7007195c6415de.zip
dev-util/ydiff: Python 3.12
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'dev-util/ydiff')
-rw-r--r--dev-util/ydiff/ydiff-1.2-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-util/ydiff/ydiff-1.2-r2.ebuild b/dev-util/ydiff/ydiff-1.2-r2.ebuild
new file mode 100644
index 000000000000..3f16531fa948
--- /dev/null
+++ b/dev-util/ydiff/ydiff-1.2-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Colored, side-by-side diff terminal viewer (ex. cdiff)"
+HOMEPAGE="https://github.com/ymattw/ydiff"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="sys-apps/less"
+
+DOCS=( CHANGES.rst README.rst )
+
+RESTRICT="test"
+
+python_test() {
+ ${PYTHON} tests/test_ydiff.py || die "Unit tests failed."
+
+ ./tests/regression.sh || die "Regression tests failed."
+}