summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2023-09-03 20:38:30 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2024-10-18 22:21:33 +0300
commit2313dc28f90a76ea855f7a5eb2d881069c9e8864 (patch)
treeb391a94fe0f624847177356c51903c0ea6034e11 /dev-util
parentapp-shells/bash: add 5.3_alpha_p20241018 (diff)
downloadgentoo-2313dc28f90a76ea855f7a5eb2d881069c9e8864.tar.gz
gentoo-2313dc28f90a76ea855f7a5eb2d881069c9e8864.tar.bz2
gentoo-2313dc28f90a76ea855f7a5eb2d881069c9e8864.zip
dev-util/txt2regex: add 0.9
Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Closes: https://github.com/gentoo/gentoo/pull/32589 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/txt2regex/Manifest1
-rw-r--r--dev-util/txt2regex/files/txt2regex-0.9-disable-nls.patch13
-rw-r--r--dev-util/txt2regex/txt2regex-0.9.ebuild41
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-util/txt2regex/Manifest b/dev-util/txt2regex/Manifest
index dfb4d4d74272..6d90146d9312 100644
--- a/dev-util/txt2regex/Manifest
+++ b/dev-util/txt2regex/Manifest
@@ -1 +1,2 @@
DIST txt2regex-0.8.tgz 40514 BLAKE2B 938f8ec41ec1319d96928ed38985626d906788a8c2959661c2338104527a0ade3a72e4d7e13f17b2f6f9abc2589ff2aaf88dc99077bf2fd6a82a82d186efc580 SHA512 69d2a682471e3e35fbd0b2ad6f6ffab040803a17bda8082f3dd67baf3a03e7011cb20047940fb9403e180895a1258f720ca4d538187878c5989a1ec51168435f
+DIST txt2regex-0.9.tar.gz 67212 BLAKE2B 054a0a3f37bdbfb9a071b93d87b6c410c6daf3f330cbb2355f3a05b70e0665ec229b04ab2d6fc41940f44e680221638c74a937bce83825b311d78df0bc03d2b8 SHA512 1ef9173c7f4309ed30e254869b29e9919a573379191d3d8e6e78bd75f1ba776c8741c1a248e3cb65c6cb7f5402f4c30768c93c4b453888b91c9377de62af5e96
diff --git a/dev-util/txt2regex/files/txt2regex-0.9-disable-nls.patch b/dev-util/txt2regex/files/txt2regex-0.9-disable-nls.patch
new file mode 100644
index 000000000000..fc0ae57fac94
--- /dev/null
+++ b/dev-util/txt2regex/files/txt2regex-0.9-disable-nls.patch
@@ -0,0 +1,13 @@
+diff --git a/Makefile b/Makefile
+index 89c1f85..6283b1f 100644
+--- a/Makefile
++++ b/Makefile
+@@ -128,7 +128,7 @@ check-po:
+ #-----------------------------------------------------------------------
+ # Release
+
+-install: install-mo install-bin
++install: install-bin
+
+ install-mo: mo
+ test -d $(LOCALEDIR) || mkdir -p $(LOCALEDIR); \
diff --git a/dev-util/txt2regex/txt2regex-0.9.ebuild b/dev-util/txt2regex/txt2regex-0.9.ebuild
new file mode 100644
index 000000000000..9d0c4a0d52f4
--- /dev/null
+++ b/dev-util/txt2regex/txt2regex-0.9.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A Regular Expression wizard that converts human sentences to regexs"
+HOMEPAGE="https://aurelio.net/projects/txt2regex/"
+SRC_URI="https://github.com/aureliojargas/txt2regex/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="nls cjk"
+
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND=">=app-shells/bash-2.04"
+RESTRICT="test" # tests need to run in a docker container it seems
+
+src_prepare() {
+ default
+
+ # bug #93568
+ if ! use nls ; then
+ eapply "${FILESDIR}"/${P}-disable-nls.patch
+ fi
+
+ if use cjk ; then
+ sed -i -e 's/\xa4/:+:/g' "${S}"/${PN}.sh || die
+ fi
+}
+
+src_compile() {
+ # a call to emake without target will execute the tests
+ true
+}
+
+src_install() {
+ emake DESTDIR="${ED}" MANDIR="${D}"/usr/share/man/man1 install
+ dodoc CHANGELOG.md README.md TODO
+ newman man/txt2regex.man txt2regex.6
+}