summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Mego <brianmego@gmail.com>2020-07-04 09:14:20 -0500
committerJoonas Niilola <juippis@gentoo.org>2020-07-20 12:01:19 +0300
commit8cb8f1184353ad53183396e8dcb88c5fb80b98e5 (patch)
tree76ccfc4b8074a5e6116e4e323a7fb3856484369f /dev-util
parentdev-python/python-ly: update github link (diff)
downloadgentoo-8cb8f1184353ad53183396e8dcb88c5fb80b98e5.tar.gz
gentoo-8cb8f1184353ad53183396e8dcb88c5fb80b98e5.tar.bz2
gentoo-8cb8f1184353ad53183396e8dcb88c5fb80b98e5.zip
dev-util/rebar-bin: bump to 3.13.2
- Adds 3.13.2 ebuild - Updates 3.6.2 ebuild with SRC_URI name for better compatibility with distfiles cache Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Brian Mego <brianmego@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/16586 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/rebar-bin/Manifest3
-rw-r--r--dev-util/rebar-bin/rebar-bin-3.13.2.ebuild31
-rw-r--r--dev-util/rebar-bin/rebar-bin-3.6.2.ebuild8
3 files changed, 37 insertions, 5 deletions
diff --git a/dev-util/rebar-bin/Manifest b/dev-util/rebar-bin/Manifest
index da7580477903..628d2f2aa198 100644
--- a/dev-util/rebar-bin/Manifest
+++ b/dev-util/rebar-bin/Manifest
@@ -1 +1,2 @@
-DIST rebar3 694889 BLAKE2B 3a8f5562a0c984caf5d7b3ba1063a90bf110a60cea316eaf88f5199b890e186f85193dc0302b36dc31051d3552912c8d1582f563f989df97ee28364a3f47512a SHA512 8fb5c7737d70fc7a706b1e124ab660550e8637da9258338016ab2e260f1c6d662548ef723705cd18210050d052e79945578623d9e9892e08dbfdb9cb04fd89fb
+DIST rebar-bin-3.13.2 839684 BLAKE2B f7aab86b015549bb13a7fe2b3b0c64fc6b8383f46adef2fd50a080983a411f936d1c416be60eac70a2ea72439831c9a5e0e85381168ca973d6fcfbfa198e0987 SHA512 33cb7b083cd0e90159e06d6b21c1e8047cc5a2d49c469ae15449fefb8576427f2088977a294c677548f0543eb06cb25ad4c165e8df4b373e3562a7adc6125a94
+DIST rebar-bin-3.6.2 694889 BLAKE2B 3a8f5562a0c984caf5d7b3ba1063a90bf110a60cea316eaf88f5199b890e186f85193dc0302b36dc31051d3552912c8d1582f563f989df97ee28364a3f47512a SHA512 8fb5c7737d70fc7a706b1e124ab660550e8637da9258338016ab2e260f1c6d662548ef723705cd18210050d052e79945578623d9e9892e08dbfdb9cb04fd89fb
diff --git a/dev-util/rebar-bin/rebar-bin-3.13.2.ebuild b/dev-util/rebar-bin/rebar-bin-3.13.2.ebuild
new file mode 100644
index 000000000000..4f7f563c355f
--- /dev/null
+++ b/dev-util/rebar-bin/rebar-bin-3.13.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=${P#-bin}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
+HOMEPAGE="https://github.com/erlang/rebar3"
+
+SRC_URI="https://github.com/erlang/rebar3/releases/download/${PV}/rebar3 -> ${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-lang/erlang"
+DEPEND=""
+
+S="${WORKDIR}"
+
+QA_PREBUILT="/usr/bin/rebar3"
+
+src_unpack() {
+ cp -v "${DISTDIR}/${P}" "${S}/rebar3" || die
+}
+
+src_install() {
+ dobin rebar3
+}
diff --git a/dev-util/rebar-bin/rebar-bin-3.6.2.ebuild b/dev-util/rebar-bin/rebar-bin-3.6.2.ebuild
index 9835d50cdf22..4f7f563c355f 100644
--- a/dev-util/rebar-bin/rebar-bin-3.6.2.ebuild
+++ b/dev-util/rebar-bin/rebar-bin-3.6.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -9,10 +9,10 @@ MY_P=${MY_PN}-${PV}
DESCRIPTION="A sophisticated build-tool for Erlang projects that follows OTP principles"
HOMEPAGE="https://github.com/erlang/rebar3"
-SRC_URI="https://github.com/erlang/rebar3/releases/download/${PV}/rebar3"
+SRC_URI="https://github.com/erlang/rebar3/releases/download/${PV}/rebar3 -> ${P}"
LICENSE="Apache-2.0"
-SLOT="3"
+SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="dev-lang/erlang"
@@ -23,7 +23,7 @@ S="${WORKDIR}"
QA_PREBUILT="/usr/bin/rebar3"
src_unpack() {
- cp -v "${DISTDIR}/${A}" "${S}/" || die
+ cp -v "${DISTDIR}/${P}" "${S}/rebar3" || die
}
src_install() {