summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2022-06-17 23:21:57 +0800
committerYixun Lan <dlan@gentoo.org>2022-06-17 23:21:57 +0800
commitb28ced397973df2fedc1c3d9465523bf46a79784 (patch)
tree021f556b8bbb101746b46671187f8f83e8702e15 /dev-util
parentdev-util/bootconfig: fix QA issue, respect CFLAGS (diff)
downloadgentoo-b28ced397973df2fedc1c3d9465523bf46a79784.tar.gz
gentoo-b28ced397973df2fedc1c3d9465523bf46a79784.tar.bz2
gentoo-b28ced397973df2fedc1c3d9465523bf46a79784.zip
dev-util/bootconfig: QA, respect CFLAGS/LDFLAGS
Closes: https://bugs.gentoo.org/852797 Closes: https://bugs.gentoo.org/852776 Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/bootconfig/files/bootconfig-5.18-cflags.patch11
1 files changed, 10 insertions, 1 deletions
diff --git a/dev-util/bootconfig/files/bootconfig-5.18-cflags.patch b/dev-util/bootconfig/files/bootconfig-5.18-cflags.patch
index 7d6b23338935..8ce106275a24 100644
--- a/dev-util/bootconfig/files/bootconfig-5.18-cflags.patch
+++ b/dev-util/bootconfig/files/bootconfig-5.18-cflags.patch
@@ -1,5 +1,5 @@
diff --git a/Makefile b/Makefile
-index 566c3e0..21818c7 100644
+index 566c3e0..aa65fd7 100644
--- a/Makefile
+++ b/Makefile
@@ -10,7 +10,7 @@ srctree := $(patsubst %/,%,$(dir $(srctree)))
@@ -11,3 +11,12 @@ index 566c3e0..21818c7 100644
ALL_TARGETS := bootconfig
ALL_PROGRAMS := $(patsubst %,$(OUTPUT)%,$(ALL_TARGETS))
+@@ -18,7 +18,7 @@ ALL_PROGRAMS := $(patsubst %,$(OUTPUT)%,$(ALL_TARGETS))
+ all: $(ALL_PROGRAMS) test
+
+ $(OUTPUT)bootconfig: main.c include/linux/bootconfig.h $(LIBSRC)
+- $(CC) $(filter %.c,$^) $(CFLAGS) -o $@
++ $(CC) $(filter %.c,$^) $(CFLAGS) $(LDFLAGS) -o $@
+
+ test: $(ALL_PROGRAMS) test-bootconfig.sh
+ ./test-bootconfig.sh $(OUTPUT)