summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-02-15 00:55:58 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-02-15 01:24:31 -0500
commitb6605109c1c037e96db4edebd6c17d167719c352 (patch)
tree65c1e6bd380706e64612120b6b7c9cfc35e8b050 /dev-util
parentdev-games/godot: add 4.0_rc2 (diff)
downloadgentoo-b6605109c1c037e96db4edebd6c17d167719c352.tar.gz
gentoo-b6605109c1c037e96db4edebd6c17d167719c352.tar.bz2
gentoo-b6605109c1c037e96db4edebd6c17d167719c352.zip
dev-util/maturin: enable password-storage in 1.0.0_beta1
This matches upstream releases (.github/workflows/release.yml), like rustls it's not always enabled because it comes with caveats (in this case doesn't work on *BSD but we're Linux). Also change the way it's handled a bit, so it's less confusing and easier to edit. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/maturin/maturin-1.0.0_beta1-r1.ebuild (renamed from dev-util/maturin/maturin-1.0.0_beta1.ebuild)16
1 files changed, 9 insertions, 7 deletions
diff --git a/dev-util/maturin/maturin-1.0.0_beta1.ebuild b/dev-util/maturin/maturin-1.0.0_beta1-r1.ebuild
index 44299f0b5696..c3aba92597fc 100644
--- a/dev-util/maturin/maturin-1.0.0_beta1.ebuild
+++ b/dev-util/maturin/maturin-1.0.0_beta1-r1.ebuild
@@ -452,15 +452,17 @@ src_prepare() {
src_configure() {
filter-lto # TODO: cleanup after bug #893658
- # no features if empty (pep517-only), this re-enables them like releases do
- export MATURIN_SETUP_ARGS=" "
-
- # cargo.eclass adds IUSE=debug, avoid it being a noop
- use debug && MATURIN_SETUP_ARGS+=" --profile dev"
+ local cargoargs=(
+ $(usev debug '--profile dev')
+ --no-default-features
+ --features full,password-storage # see release.yml
+ )
# rustls needs ring crate that only works on specific arches (bug #859577)
- use !amd64 && use !x86 && use !arm64 && use !arm &&
- MATURIN_SETUP_ARGS+=" --no-default-features --features full"
+ use amd64 || use x86 || use arm64 || use arm &&
+ cargoargs+=(--features rustls)
+
+ export MATURIN_SETUP_ARGS=${cargoargs[*]} # --no-default-features if empty
}
python_compile_all() {