summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew White <mehw.is.me@inventati.org>2023-01-20 08:09:58 +0000
committerJoonas Niilola <juippis@gentoo.org>2023-02-10 10:56:42 +0200
commitb924a78400249ae434557c8dfb8a8f5a0eafdec2 (patch)
tree901c2597dc2bc8aacb1488b2d97f181c7302203e /dev-util
parentdev-util/unicorn: forward keywords to live ebuild (diff)
downloadgentoo-b924a78400249ae434557c8dfb8a8f5a0eafdec2.tar.gz
gentoo-b924a78400249ae434557c8dfb8a8f5a0eafdec2.tar.bz2
gentoo-b924a78400249ae434557c8dfb8a8f5a0eafdec2.zip
dev-util/codeblocks: use bundled dev-lang/squirrel
Fix a compiling issue when dev-lang/squirrel is installed. Upstream disabled the use of system wide squirrel in favor of the bundled version. Do not use the system's /usr/include/squirrel.h header, since the API may have been changed. r12418 | fuscated | 2021-05-09 14:50:21 +0200 (Sun, 09 May 2021) | 5 lines $ svn checkout svn://svn.code.sf.net/p/codeblocks/code/trunk $ cd trunk $ svn log --diff configure.ac@r12418 In the ebuild, sed expression and comments by band-a-prend. Closes: https://bugs.gentoo.org/884601 Package-Manager: portage-3.0.43-r1, pkgdev-0.2.4 Closes: https://github.com/gentoo/gentoo/pull/29186 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/codeblocks/codeblocks-20.03-r6.ebuild94
1 files changed, 94 insertions, 0 deletions
diff --git a/dev-util/codeblocks/codeblocks-20.03-r6.ebuild b/dev-util/codeblocks/codeblocks-20.03-r6.ebuild
new file mode 100644
index 000000000000..33e87a9e4106
--- /dev/null
+++ b/dev-util/codeblocks/codeblocks-20.03-r6.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.0-gtk3"
+
+inherit autotools flag-o-matic wxwidgets xdg
+
+DESCRIPTION="The open source, cross platform, free C, C++ and Fortran IDE"
+HOMEPAGE="https://codeblocks.org/"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz
+ https://dev.gentoo.org/~leio/distfiles/${P}-fortran.tar.xz
+ https://dev.gentoo.org/~leio/distfiles/${P}-fortran-update-v1.7.tar.xz
+ https://dev.gentoo.org/~leio/distfiles/${P}-fortran-update-v1.8.tar.xz
+ https://dev.gentoo.org/~leio/distfiles/${P}-codecompletion-symbolbrowser-update.tar.xz
+"
+
+# USE="fortran" enables FortranProject plugin (updated to v1.8 2021-05-29 [r230])
+# that is delivered with Code::Blocks 20.03 source code.
+# https://sourceforge.net/projects/fortranproject
+# https://cbfortran.sourceforge.io
+
+IUSE="contrib debug fortran"
+
+BDEPEND="virtual/pkgconfig"
+
+RDEPEND="app-arch/zip
+ dev-libs/glib:2
+ >=dev-libs/tinyxml-2.6.2-r3
+ >=dev-util/astyle-3.1-r2:0/3.1
+ x11-libs/gtk+:3
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ contrib? (
+ app-admin/gamin
+ app-arch/bzip2
+ app-text/hunspell:=
+ dev-libs/libgamin
+ media-libs/fontconfig
+ sys-libs/zlib
+ )"
+
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-env.patch
+ "${WORKDIR}"/patches/
+ )
+
+src_prepare() {
+ default
+ # Force to use bundled Squirrel-3.1 (patched version is used by upstream) due to it's API was changed
+ sed -i '/PKG_CHECK_MODULES(\[SQUIRREL\]/c\HAVE_SQUIRREL=no' configure.ac || die # Bug 884601
+ eautoreconf
+}
+
+src_configure() {
+ # Bug 858338
+ append-flags -fno-strict-aliasing
+
+ setup-wxwidgets
+
+ # USE="contrib -fortran" setup:
+ use fortran || CONF_WITH_LST=$(use_with contrib contrib-plugins all,-FortranProject)
+ # USE="contrib fortran" setup:
+ use fortran && CONF_WITH_LST=$(use_with contrib contrib-plugins all)
+ # USE="-contrib fortran" setup:
+ use contrib || CONF_WITH_LST=$(use_with fortran contrib-plugins FortranProject)
+
+ local myeconfargs=(
+ --disable-pch
+ $(use_with contrib boost-libdir "${ESYSROOT}/usr/$(get_libdir)")
+ $(use_enable debug)
+ ${CONF_WITH_LST}
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+}