summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-10-21 13:00:38 -0500
committerWilliam Hubbs <williamh@gentoo.org>2024-10-21 13:01:05 -0500
commite07f54c8014c3e2ddfb8554268550509a108718c (patch)
tree5ddd2a9d5dd5bcff066c6fb63052ad131abca4f1 /dev-util
parentsci-geosciences/merkaartor: add 0.20.0 (diff)
downloadgentoo-e07f54c8014c3e2ddfb8554268550509a108718c.tar.gz
gentoo-e07f54c8014c3e2ddfb8554268550509a108718c.tar.bz2
gentoo-e07f54c8014c3e2ddfb8554268550509a108718c.zip
dev-util/gitlab-runner: add 17.4.1
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-17.4.1.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index 542e3ce3b23b..0e356b02ac84 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -4,3 +4,5 @@ DIST gitlab-runner-17.2.1-deps.tar.xz 86661500 BLAKE2B 96700ef116677e2fa0d223347
DIST gitlab-runner-17.2.1.tar.bz2 1378845 BLAKE2B 649217da0c358e8db87758c72bd69897b1d9edd0b9e9d92c9a42ce7b39b5fa8bef7a07faf107584d90aae8ce292e0625b2a021294cd9b8cff73c02d086a5cda7 SHA512 3c14643da0884bc6bdf1eebfababb1ffa7d2ecf93ec1b0e708aef143b8a9519bc7d27fb6a3fdf6f6fb5b04511a8f1cfd9622c9c5db4365c879dc30c8a4d59cb6
DIST gitlab-runner-17.3.1-deps.tar.xz 86653516 BLAKE2B e7ac6d3218528f5a33f727a3e27a435fc2cb676e36e952892e656122f9c9e986806a1023ce8b03e4bb07e5829b7595f8ebc8a184456fe5f067745b55d1550a8b SHA512 c28edf4af1e1cb0966eb45e2d1f3b7b0f1312892e20d2cf87321e29eacbdc37b4e6b3d92f02c7b8a4cd0b4f8fc3e85d58f6ce208e4650400547fd093efa84715
DIST gitlab-runner-17.3.1.tar.bz2 1382824 BLAKE2B 58086f5964776ecc08d25c817e4460f5874f4b8def14aaab46f7e94157a2b801f42e0656c13190c3272fb43b3213ac253ed329563cf67e292a57f48d1fd0e7ce SHA512 67be67ed3e3c5136f6adad17c85080d6470f8a7082080fe7026609b42868de454dd1f8aa750087ecf23a02fdd1c2d00d7797638d0f9be070103574ea1a1c491b
+DIST gitlab-runner-17.4.1-deps.tar.xz 104751932 BLAKE2B a4db4d8f739343a5648379d60717ec9df9526f481799dd4e8eb106167ea835a16e13b60d72a96a11d5d6ed9094ab099af82c86f061d8d85ea360d47e663876b7 SHA512 df4fdbdf242e52ca1ec1f54664646c5275561060b30e12c51d6ef41bdba5b8836e0c2a303b17ddead64dd946a9a01d191adbaadbf2f3eee7ebfc5bcda3746406
+DIST gitlab-runner-17.4.1.tar.bz2 1407772 BLAKE2B 9185590409a53b511b12eb562d0765b95c202052fe2bc7c6aac334a298fd0af50cab3118079cfa42eb6ec0f7f767de0dadd036a5a888217f9742d8c5097a92e3 SHA512 be77f5e24aad129845cc0c66b19fe4cf673eb43e5a0b37a146d53a1cc114851340bfd08e23c78b8f9c4372ccee35dd541ac646abfd72906fb16c0d7fcca8e1d9
diff --git a/dev-util/gitlab-runner/gitlab-runner-17.4.1.ebuild b/dev-util/gitlab-runner/gitlab-runner-17.4.1.ebuild
new file mode 100644
index 000000000000..b18cf6e1bed9
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-17.4.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=32fe5502
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 ~riscv"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}