summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2022-08-09 08:23:03 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2022-08-09 08:23:03 -0400
commit80d6921f3fcddb81eda183d046fb2a2549a718f9 (patch)
tree6e352d5dcf2204810ea5fe670c47c84263a244c4 /dev-vcs/fossil
parentdev-python/astroid: amd64/arm64/arm/hppa/ppc64/ppc/sparc/x86 stable (ALLARCHE... (diff)
downloadgentoo-80d6921f3fcddb81eda183d046fb2a2549a718f9.tar.gz
gentoo-80d6921f3fcddb81eda183d046fb2a2549a718f9.tar.bz2
gentoo-80d6921f3fcddb81eda183d046fb2a2549a718f9.zip
dev-vcs/fossil: Cleanup old
Signed-off-by: Aaron W. Swenson <titanofold@gentoo.org>
Diffstat (limited to 'dev-vcs/fossil')
-rw-r--r--dev-vcs/fossil/Manifest1
-rw-r--r--dev-vcs/fossil/fossil-2.18.ebuild81
2 files changed, 0 insertions, 82 deletions
diff --git a/dev-vcs/fossil/Manifest b/dev-vcs/fossil/Manifest
index a07aa4141718..0170a6c0fdee 100644
--- a/dev-vcs/fossil/Manifest
+++ b/dev-vcs/fossil/Manifest
@@ -1,3 +1,2 @@
DIST fossil-src-2.16.tar.gz 6275775 BLAKE2B 504f828f121385ec73311b340e0abfdba7da6a8571adb390c55c75fea0ef027366fb914c12552e177988bedbb735a3148d87ebdb23ffc2ce4b7bef8ef603692a SHA512 0569640a3b509c592f812a42526eec88ead034ba0ba3de93da62cfb1caa751954ae185eaa3398d411a02ee2a858ecae6cdf4e47199847527f7524fc9798a4b12
-DIST fossil-src-2.18.tar.gz 6308652 BLAKE2B 299406d365e24c139e8bfbf94dc0aee2c04aa02a9f4c48d1425d0f6d21830aece10cbc5a38cee18cec03d3d0f39db3726d4890c09ca9bfc84a5058e76756ed4d SHA512 9dfeef1cc394af7afc6b68d2ebf084d5962698123518999130162718d450d061ab286b5f4039cde1af0e17059a9c801f1ded974fdb78b0965b73a7f8c80fd277
DIST fossil-src-2.19.tar.gz 6435868 BLAKE2B 414dd8b1630bb6a8bcc22f3528da60386663e7f31191e5134474e37211e55323af45947452a0f09e21964dd3cd94ca6cf6e34ecd74e0d3e4f0dce7a50146f0ff SHA512 fcd84df2d84c3a958bb19228de4320456382d3c925717c58bec42de86d96383a9208fb31ba6aaeccd9bc6bba949048d5c1ce3d2b3e8535951956ae18d9aa34e4
diff --git a/dev-vcs/fossil/fossil-2.18.ebuild b/dev-vcs/fossil/fossil-2.18.ebuild
deleted file mode 100644
index 6c43488232b7..000000000000
--- a/dev-vcs/fossil/fossil-2.18.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit toolchain-funcs
-
-MY_TAG=84f25d7eb10c0714109d69bb2809abfa8b4b5c3d73b151a5b10df724dacd46d8
-
-DESCRIPTION="Simple, high-reliability, source control management, and more"
-HOMEPAGE="https://www.fossil-scm.org/"
-SRC_URI="https://fossil-scm.org/home/tarball/${MY_TAG}/fossil-src-${PV}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~x86"
-IUSE="debug fusefs json miniz system-sqlite +ssl static tcl tcl-stubs
- tcl-private-stubs th1-docs th1-hooks"
-
-REQUIRED_USE="ssl? ( !miniz )"
-
-# Please check sqlite minimum version on every release.
-# This can be done with ./configure --print-minimum-sqlite-version.
-RDEPEND="
- sys-libs/zlib
- || (
- sys-libs/readline:0
- dev-libs/libedit
- )
- system-sqlite? ( >=dev-db/sqlite-3.38.0:3 )
- ssl? ( dev-libs/openssl:0= )
- tcl? ( dev-lang/tcl:0= )
-"
-
-# Either tcl or jimtcl need to be present to build Fossil (Bug #675778)
-DEPEND="${RDEPEND}
- !tcl? (
- || (
- dev-lang/tcl:*
- dev-lang/jimtcl:*
- )
- )
-"
-
-# Tests can't be run from the build directory
-RESTRICT="test"
-
-PATCHES=(
- # fossil-2.10-check-lib64-for-tcl.patch: Bug 690828
- "${FILESDIR}"/fossil-2.10-check-lib64-for-tcl.patch
- # sqlite-3.38 patch should be in next release
- "${FILESDIR}"/${P}-fix-sqlite-3.38-json-check.patch
-)
-
-S="${WORKDIR}/fossil-src-${PV}"
-
-src_configure() {
- # this is not an autotools situation so don't make it seem like one
- # --with-tcl: works
- # --without-tcl: dies
- local myconf="--with-openssl=$(usex ssl auto none)"
- use debug && myconf+=' --fossil-debug'
- use json && myconf+=' --json'
- use system-sqlite && myconf+=' --disable-internal-sqlite'
- use static && myconf+=' --static'
- use tcl && myconf+=' --with-tcl=1'
- use fusefs || myconf+=' --disable-fusefs'
-
- local u useflags
- useflags=( miniz tcl-stubs tcl-private-stubs th1-docs th1-hooks )
- for u in ${useflags[@]} ; do
- use ${u} && myconf+=" --with-${u}"
- done
-
- tc-export CC CXX
- CC_FOR_BUILD=${CC} ./configure ${myconf} || die
-}
-
-src_install() {
- dobin fossil
-}