summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-11-27 10:01:55 -0500
committerMike Gilbert <floppym@gentoo.org>2017-11-27 10:02:23 -0500
commitdd563b06e0833b9cfeda1c91cedf3ff0ed933ba7 (patch)
tree4f2a306288ab31a9e333ec58ae3b5df58112dc13 /dev-vcs/git-tools/git-tools-2017.10.ebuild
parentsys-libs/musl: remove vulnerable version, bug #636060 (diff)
downloadgentoo-dd563b06e0833b9cfeda1c91cedf3ff0ed933ba7.tar.gz
gentoo-dd563b06e0833b9cfeda1c91cedf3ff0ed933ba7.tar.bz2
gentoo-dd563b06e0833b9cfeda1c91cedf3ff0ed933ba7.zip
dev-vcs/git-tools: bump to 2017.10
Simplify src_install. Drop git-core symlinks; git(1) looks for helpers in PATH. Package-Manager: Portage-2.3.15, Repoman-2.3.6_p7
Diffstat (limited to 'dev-vcs/git-tools/git-tools-2017.10.ebuild')
-rw-r--r--dev-vcs/git-tools/git-tools-2017.10.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-vcs/git-tools/git-tools-2017.10.ebuild b/dev-vcs/git-tools/git-tools-2017.10.ebuild
new file mode 100644
index 000000000000..b5eaaffb3d63
--- /dev/null
+++ b/dev-vcs/git-tools/git-tools-2017.10.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit eutils python-r1
+
+DESCRIPTION="Assorted git-related scripts"
+HOMEPAGE="https://github.com/MestreLion/git-tools"
+SRC_URI="https://github.com/MestreLion/git-tools/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ >=dev-vcs/git-2.5
+ >=app-shells/bash-4.0"
+
+src_install() {
+ dobin git-branches-rename git-clone-subset git-find-uncommitted-repos
+ dobin git-rebase-theirs git-strip-merge
+ python_foreach_impl python_doscript git-restore-mtime
+ doman man1/*.1
+ einstalldocs
+}