summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /dev-vcs
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/cssc/cssc-1.4.0.ebuild3
-rw-r--r--dev-vcs/cssc/cssc-1.4.1.ebuild1
-rw-r--r--dev-vcs/cvs2svn/cvs2svn-2.4.0-r1.ebuild1
-rw-r--r--dev-vcs/cvs2svn/cvs2svn-2.5.0.ebuild1
-rw-r--r--dev-vcs/darcs/darcs-2.8.4-r6.ebuild1
-rw-r--r--dev-vcs/git-cola/git-cola-2.11.ebuild1
-rw-r--r--dev-vcs/git-cola/git-cola-3.2.ebuild3
-rw-r--r--dev-vcs/git-deploy/git-deploy-6.0.1_p20131024-r1.ebuild1
-rw-r--r--dev-vcs/git-mantle/git-mantle-0.6.ebuild3
-rw-r--r--dev-vcs/git-pimp/git-pimp-0.8.ebuild3
-rw-r--r--dev-vcs/gitinspector/gitinspector-0.4.4.ebuild3
-rw-r--r--dev-vcs/hgsubversion/hgsubversion-1.9.2.ebuild1
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-1.13.0.ebuild1
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-1.7.0.ebuild1
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-1.8.0.ebuild1
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-1.9.0.ebuild1
-rw-r--r--dev-vcs/subversion/subversion-1.12.2.ebuild1
-rw-r--r--dev-vcs/subversion/subversion-1.13.0.ebuild1
18 files changed, 23 insertions, 5 deletions
diff --git a/dev-vcs/cssc/cssc-1.4.0.ebuild b/dev-vcs/cssc/cssc-1.4.0.ebuild
index 2f891e4d3c0e..e1e1659be646 100644
--- a/dev-vcs/cssc/cssc-1.4.0.ebuild
+++ b/dev-vcs/cssc/cssc-1.4.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -17,6 +17,7 @@ LICENSE="GPL-3"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="test valgrind"
+RESTRICT="!test? ( test )"
DEPEND="
test? ( valgrind? ( dev-util/valgrind ) )
diff --git a/dev-vcs/cssc/cssc-1.4.1.ebuild b/dev-vcs/cssc/cssc-1.4.1.ebuild
index c2b8b544df5e..39514fabd0b8 100644
--- a/dev-vcs/cssc/cssc-1.4.1.ebuild
+++ b/dev-vcs/cssc/cssc-1.4.1.ebuild
@@ -15,6 +15,7 @@ LICENSE="GPL-3"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE="test valgrind"
+RESTRICT="!test? ( test )"
DEPEND="
test? ( valgrind? ( dev-util/valgrind ) )
"
diff --git a/dev-vcs/cvs2svn/cvs2svn-2.4.0-r1.ebuild b/dev-vcs/cvs2svn/cvs2svn-2.4.0-r1.ebuild
index 8f54c70877ef..f62aa0e9d40b 100644
--- a/dev-vcs/cvs2svn/cvs2svn-2.4.0-r1.ebuild
+++ b/dev-vcs/cvs2svn/cvs2svn-2.4.0-r1.ebuild
@@ -18,6 +18,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="alpha amd64 ia64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="bazaar git test"
+RESTRICT="!test? ( test )"
DEPEND=">=dev-vcs/subversion-1.0.9"
RDEPEND="${DEPEND}
diff --git a/dev-vcs/cvs2svn/cvs2svn-2.5.0.ebuild b/dev-vcs/cvs2svn/cvs2svn-2.5.0.ebuild
index 8d1c4ed57dcb..54254fc1f2ff 100644
--- a/dev-vcs/cvs2svn/cvs2svn-2.5.0.ebuild
+++ b/dev-vcs/cvs2svn/cvs2svn-2.5.0.ebuild
@@ -18,6 +18,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="bazaar git test"
+RESTRICT="!test? ( test )"
DEPEND=">=dev-vcs/subversion-1.0.9"
RDEPEND="${DEPEND}
diff --git a/dev-vcs/darcs/darcs-2.8.4-r6.ebuild b/dev-vcs/darcs/darcs-2.8.4-r6.ebuild
index 24dfff4302fd..85d765676744 100644
--- a/dev-vcs/darcs/darcs-2.8.4-r6.ebuild
+++ b/dev-vcs/darcs/darcs-2.8.4-r6.ebuild
@@ -16,6 +16,7 @@ LICENSE="GPL-2"
SLOT="0/${PV}"
KEYWORDS="alpha amd64 ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND="=dev-haskell/extensible-exceptions-0.1*:=[profile?]
>=dev-haskell/hashed-storage-0.5.6:=[profile?]
diff --git a/dev-vcs/git-cola/git-cola-2.11.ebuild b/dev-vcs/git-cola/git-cola-2.11.ebuild
index aa749f760c10..098941ec4099 100644
--- a/dev-vcs/git-cola/git-cola-2.11.ebuild
+++ b/dev-vcs/git-cola/git-cola-2.11.ebuild
@@ -16,6 +16,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
IUSE="doc test"
+RESTRICT="!test? ( test )"
# Since PyQt5 is preferred at runtime if installed, depend on that
RDEPEND="
diff --git a/dev-vcs/git-cola/git-cola-3.2.ebuild b/dev-vcs/git-cola/git-cola-3.2.ebuild
index 02897b8b6a98..42482ec26a6e 100644
--- a/dev-vcs/git-cola/git-cola-3.2.ebuild
+++ b/dev-vcs/git-cola/git-cola-3.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -16,6 +16,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-python/QtPy[gui,${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
diff --git a/dev-vcs/git-deploy/git-deploy-6.0.1_p20131024-r1.ebuild b/dev-vcs/git-deploy/git-deploy-6.0.1_p20131024-r1.ebuild
index 3e27f1ef8e6d..f7e78a6147c7 100644
--- a/dev-vcs/git-deploy/git-deploy-6.0.1_p20131024-r1.ebuild
+++ b/dev-vcs/git-deploy/git-deploy-6.0.1_p20131024-r1.ebuild
@@ -16,6 +16,7 @@ LICENSE="|| ( Artistic GPL-1 GPL-2 GPL-3 )"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
COMMON_DEPEND="dev-vcs/git
virtual/perl-File-Spec
diff --git a/dev-vcs/git-mantle/git-mantle-0.6.ebuild b/dev-vcs/git-mantle/git-mantle-0.6.ebuild
index 08268e572163..e65f66b598e6 100644
--- a/dev-vcs/git-mantle/git-mantle-0.6.ebuild
+++ b/dev-vcs/git-mantle/git-mantle-0.6.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -11,6 +11,7 @@ SRC_URI="http://codex.sigpipe.cz/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
IUSE="test"
+RESTRICT="!test? ( test )"
KEYWORDS="~amd64 ~x86"
diff --git a/dev-vcs/git-pimp/git-pimp-0.8.ebuild b/dev-vcs/git-pimp/git-pimp-0.8.ebuild
index 900a55ad38e0..9e46d70afc0b 100644
--- a/dev-vcs/git-pimp/git-pimp-0.8.ebuild
+++ b/dev-vcs/git-pimp/git-pimp-0.8.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -11,6 +11,7 @@ SRC_URI="http://codex.sigpipe.cz/${PN}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
IUSE="test"
+RESTRICT="!test? ( test )"
KEYWORDS="~amd64 ~x86"
diff --git a/dev-vcs/gitinspector/gitinspector-0.4.4.ebuild b/dev-vcs/gitinspector/gitinspector-0.4.4.ebuild
index 8a2f93873ec8..2dec61aeaf4e 100644
--- a/dev-vcs/gitinspector/gitinspector-0.4.4.ebuild
+++ b/dev-vcs/gitinspector/gitinspector-0.4.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -15,6 +15,7 @@ SLOT="0"
LICENSE="GPL-3+"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="dev-vcs/git"
DEPEND="test? ( ${RDEPEND} )"
diff --git a/dev-vcs/hgsubversion/hgsubversion-1.9.2.ebuild b/dev-vcs/hgsubversion/hgsubversion-1.9.2.ebuild
index 2abc37c6b0a5..d83432918135 100644
--- a/dev-vcs/hgsubversion/hgsubversion-1.9.2.ebuild
+++ b/dev-vcs/hgsubversion/hgsubversion-1.9.2.ebuild
@@ -14,6 +14,7 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86 ~ppc-macos ~x64-macos ~x86-solaris"
IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND="
>=dev-vcs/mercurial-1.4[${PYTHON_USEDEP}]
diff --git a/dev-vcs/python-gitlab/python-gitlab-1.13.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-1.13.0.ebuild
index 2ee27c73fd03..5a890390ea5d 100644
--- a/dev-vcs/python-gitlab/python-gitlab-1.13.0.ebuild
+++ b/dev-vcs/python-gitlab/python-gitlab-1.13.0.ebuild
@@ -20,6 +20,7 @@ HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
LICENSE="LGPL-3"
SLOT="0"
IUSE="test"
+RESTRICT="!test? ( test )"
BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? (
diff --git a/dev-vcs/python-gitlab/python-gitlab-1.7.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-1.7.0.ebuild
index 2ee27c73fd03..5a890390ea5d 100644
--- a/dev-vcs/python-gitlab/python-gitlab-1.7.0.ebuild
+++ b/dev-vcs/python-gitlab/python-gitlab-1.7.0.ebuild
@@ -20,6 +20,7 @@ HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
LICENSE="LGPL-3"
SLOT="0"
IUSE="test"
+RESTRICT="!test? ( test )"
BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? (
diff --git a/dev-vcs/python-gitlab/python-gitlab-1.8.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-1.8.0.ebuild
index 2ee27c73fd03..5a890390ea5d 100644
--- a/dev-vcs/python-gitlab/python-gitlab-1.8.0.ebuild
+++ b/dev-vcs/python-gitlab/python-gitlab-1.8.0.ebuild
@@ -20,6 +20,7 @@ HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
LICENSE="LGPL-3"
SLOT="0"
IUSE="test"
+RESTRICT="!test? ( test )"
BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? (
diff --git a/dev-vcs/python-gitlab/python-gitlab-1.9.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-1.9.0.ebuild
index 2ee27c73fd03..5a890390ea5d 100644
--- a/dev-vcs/python-gitlab/python-gitlab-1.9.0.ebuild
+++ b/dev-vcs/python-gitlab/python-gitlab-1.9.0.ebuild
@@ -20,6 +20,7 @@ HOMEPAGE="https://github.com/python-gitlab/python-gitlab/"
LICENSE="LGPL-3"
SLOT="0"
IUSE="test"
+RESTRICT="!test? ( test )"
BDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? (
diff --git a/dev-vcs/subversion/subversion-1.12.2.ebuild b/dev-vcs/subversion/subversion-1.12.2.ebuild
index 4674e4e7880c..f487c2a61bd4 100644
--- a/dev-vcs/subversion/subversion-1.12.2.ebuild
+++ b/dev-vcs/subversion/subversion-1.12.2.ebuild
@@ -23,6 +23,7 @@ SLOT="0"
[[ "${PV}" = *_rc* ]] || \
KEYWORDS="alpha amd64 arm arm64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
IUSE="apache2 berkdb ctypes-python debug doc +dso extras gnome-keyring +http java kwallet nls perl python ruby sasl test vim-syntax"
+RESTRICT="!test? ( test )"
COMMON_DEPEND="
app-arch/bzip2
diff --git a/dev-vcs/subversion/subversion-1.13.0.ebuild b/dev-vcs/subversion/subversion-1.13.0.ebuild
index f8eddc1f4a1a..b309ede0baea 100644
--- a/dev-vcs/subversion/subversion-1.13.0.ebuild
+++ b/dev-vcs/subversion/subversion-1.13.0.ebuild
@@ -23,6 +23,7 @@ SLOT="0"
[[ "${PV}" = *_rc* ]] || \
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
IUSE="apache2 berkdb ctypes-python debug doc +dso extras gnome-keyring +http java kwallet nls perl python ruby sasl test vim-syntax"
+RESTRICT="!test? ( test )"
COMMON_DEPEND="
app-arch/bzip2