summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-10-01 08:46:22 +0100
committerSam James <sam@gentoo.org>2024-10-01 08:46:22 +0100
commit80f7aebfa94401e62f9f8132cf2fe16b51d9be40 (patch)
tree2dded30da0b1a5d2b8d358610db86c54a50c0f00 /eclass/toolchain.eclass
parentdev-lang/ada-bootstrap: more PATH fixes (diff)
downloadgentoo-80f7aebfa94401e62f9f8132cf2fe16b51d9be40.tar.gz
gentoo-80f7aebfa94401e62f9f8132cf2fe16b51d9be40.tar.bz2
gentoo-80f7aebfa94401e62f9f8132cf2fe16b51d9be40.zip
toolchain.eclass: don't pass --specs= to gnat* tools
The gnat* tools don't understand --specs=* and we only need to do that to ensure the compiler driver (gcc) calls the right things anyway. What we might have to do in future however is force --gcc and --link... Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'eclass/toolchain.eclass')
-rw-r--r--eclass/toolchain.eclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/eclass/toolchain.eclass b/eclass/toolchain.eclass
index a9f02d6d6a46..7b302afdf5cc 100644
--- a/eclass/toolchain.eclass
+++ b/eclass/toolchain.eclass
@@ -982,7 +982,7 @@ toolchain_setup_ada() {
for tool in gnat{,bind,chop,clean,kr,link,ls,make,name,prep} ; do
cat <<-EOF > "${T}"/ada-wrappers/${tool} || die
#!/bin/sh
- exec $(type -P ${CBUILD}-${tool}-${ada_bootstrap}) --specs=${T}/ada.spec "\$@"
+ exec $(type -P ${CBUILD}-${tool}-${ada_bootstrap}) "\$@"
EOF
export "${tool^^}"="${T}"/ada-wrappers/${tool}