summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThiago Donato Ferreira <flowlnlnln@gmail.com>2023-11-08 19:36:21 -0300
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2023-11-09 08:47:10 +0100
commit111127c008c0f37857692cb8ca86ad973a8c34cb (patch)
treeca3c3f8118263fdcb31d4d06c8a1e4e074ea0d6b /games-action
parentgames-action/prismlauncher: drop 7.1 (diff)
downloadgentoo-111127c008c0f37857692cb8ca86ad973a8c34cb.tar.gz
gentoo-111127c008c0f37857692cb8ca86ad973a8c34cb.tar.bz2
gentoo-111127c008c0f37857692cb8ca86ad973a8c34cb.zip
games-action/prismlauncher: remove CMAKE_CXX_FLAGS_RELEASE from upstream
According to the CMake documentation, the CMAKE_<LANG>_FLAGS_<CONFIG> flags will always be added after the CMAKE_<LANG>_FLAGS, which are the ones affected by the CXXFLAGS environment variable Gentoo uses. So, as to not override the user settings, we remove the line that sets that variable, handling both the -D_FORTIFY_SOURCE=2 and -O2 flags. CMake reference: https://cmake.org/cmake/help/v3.28/variable/CMAKE_LANG_FLAGS.html#variable:CMAKE_%3CLANG%3E_FLAGS Closes: https://bugs.gentoo.org/911858 Signed-off-by: Thiago Donato Ferreira <flowlnlnln@gmail.com> Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/prismlauncher/prismlauncher-7.2-r1.ebuild (renamed from games-action/prismlauncher/prismlauncher-7.2.ebuild)6
-rw-r--r--games-action/prismlauncher/prismlauncher-9999.ebuild6
2 files changed, 8 insertions, 4 deletions
diff --git a/games-action/prismlauncher/prismlauncher-7.2.ebuild b/games-action/prismlauncher/prismlauncher-7.2-r1.ebuild
index 1d4b9a04996f..c60586d65332 100644
--- a/games-action/prismlauncher/prismlauncher-7.2.ebuild
+++ b/games-action/prismlauncher/prismlauncher-7.2-r1.ebuild
@@ -108,9 +108,11 @@ RDEPEND="
src_prepare() {
cmake_src_prepare
+ sed -i -e 's/-Werror//' CMakeLists.txt || die 'Failed to remove -Werror via sed'
+
# Prevent conflicting with the user's flags
- # See https://bugs.gentoo.org/848765 for more info
- sed -i -e 's/-Werror//' -e 's/-D_FORTIFY_SOURCE=2//' CMakeLists.txt || die 'Failed to remove -Werror and -D_FORTIFY_SOURCE via sed'
+ # See https://bugs.gentoo.org/848765 and https://bugs.gentoo.org/911858 for more info
+ sed -i -e "/CMAKE_CXX_FLAGS_RELEASE/d" CMakeLists.txt || die 'Failed to remove "CMAKE_CXX_FLAGS_RELEASE" from CMakeLists via sed'
}
src_configure(){
diff --git a/games-action/prismlauncher/prismlauncher-9999.ebuild b/games-action/prismlauncher/prismlauncher-9999.ebuild
index 1d4b9a04996f..c60586d65332 100644
--- a/games-action/prismlauncher/prismlauncher-9999.ebuild
+++ b/games-action/prismlauncher/prismlauncher-9999.ebuild
@@ -108,9 +108,11 @@ RDEPEND="
src_prepare() {
cmake_src_prepare
+ sed -i -e 's/-Werror//' CMakeLists.txt || die 'Failed to remove -Werror via sed'
+
# Prevent conflicting with the user's flags
- # See https://bugs.gentoo.org/848765 for more info
- sed -i -e 's/-Werror//' -e 's/-D_FORTIFY_SOURCE=2//' CMakeLists.txt || die 'Failed to remove -Werror and -D_FORTIFY_SOURCE via sed'
+ # See https://bugs.gentoo.org/848765 and https://bugs.gentoo.org/911858 for more info
+ sed -i -e "/CMAKE_CXX_FLAGS_RELEASE/d" CMakeLists.txt || die 'Failed to remove "CMAKE_CXX_FLAGS_RELEASE" from CMakeLists via sed'
}
src_configure(){