summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThiago Donato Ferreira <flowlnlnln@gmail.com>2022-07-03 14:22:02 -0300
committerSam James <sam@gentoo.org>2022-07-29 04:15:01 +0100
commit7d1bfe7604fa0f9f40e82430053df5f71e2cb8d7 (patch)
treeb85317450c9f4cb93b78cb7bf8a7af4ba8362151 /games-action
parentgames-action/polymc: add new optional features (diff)
downloadgentoo-7d1bfe7604fa0f9f40e82430053df5f71e2cb8d7.tar.gz
gentoo-7d1bfe7604fa0f9f40e82430053df5f71e2cb8d7.tar.bz2
gentoo-7d1bfe7604fa0f9f40e82430053df5f71e2cb8d7.zip
games-action/polymc: add tests
Following fixes by upstream, we can now run tests too :) Signed-off-by: Thiago Donato Ferreira <flowlnlnln@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/polymc/polymc-9999.ebuild5
1 files changed, 4 insertions, 1 deletions
diff --git a/games-action/polymc/polymc-9999.ebuild b/games-action/polymc/polymc-9999.ebuild
index 96537440ecbc..cc17908560c9 100644
--- a/games-action/polymc/polymc-9999.ebuild
+++ b/games-action/polymc/polymc-9999.ebuild
@@ -39,11 +39,13 @@ LICENSE="Apache-2.0 Boost-1.0 BSD BSD-2 GPL-2+ GPL-3 LGPL-3 OFL-1.1 MIT"
SLOT="0"
-IUSE="debug lto"
+IUSE="debug lto test"
REQUIRED_USE="
lto? ( !debug )
"
+RESTRICT="!test? ( test )"
+
MIN_QT="5.12.0"
QT_DEPS="
@@ -92,6 +94,7 @@ src_configure(){
-DLauncher_APP_BINARY_NAME="${PN}"
-DENABLE_LTO=$(usex lto)
+ -DBUILD_TESTING=$(usex test)
)
if use debug; then