summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-arcade/performous/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-arcade/performous/files')
-rw-r--r--games-arcade/performous/files/performous-1.0-gentoo.patch12
-rw-r--r--games-arcade/performous/files/performous-1.0-include.patch10
-rw-r--r--games-arcade/performous/files/performous-1.0-libav.patch19
-rw-r--r--games-arcade/performous/files/performous-1.0-linguas.patch18
4 files changed, 59 insertions, 0 deletions
diff --git a/games-arcade/performous/files/performous-1.0-gentoo.patch b/games-arcade/performous/files/performous-1.0-gentoo.patch
new file mode 100644
index 000000000000..a73663a88c41
--- /dev/null
+++ b/games-arcade/performous/files/performous-1.0-gentoo.patch
@@ -0,0 +1,12 @@
+diff -ru performous-1.0.orig/game/CMakeLists.txt performous-1.0/game/CMakeLists.txt
+--- performous-1.0.orig/game/CMakeLists.txt 2014-10-28 19:11:45.000000000 -0400
++++ performous-1.0/game/CMakeLists.txt 2015-03-31 03:01:30.806061643 -0400
+@@ -141,7 +141,7 @@
+ set(BIN_INSTALL .) # Straight to Program Files/Performous with no bin subfolder.
+ set(SUBSYSTEM_WIN32 WIN32)
+ else()
+- set(BIN_INSTALL bin)
++ set(BIN_INSTALL @GENTOO_BINDIR@)
+ endif()
+
+ # Build main executable
diff --git a/games-arcade/performous/files/performous-1.0-include.patch b/games-arcade/performous/files/performous-1.0-include.patch
new file mode 100644
index 000000000000..ba67018e5422
--- /dev/null
+++ b/games-arcade/performous/files/performous-1.0-include.patch
@@ -0,0 +1,10 @@
+--- performous-1.0/game/song.hh.orig 2015-03-31 13:56:13.546360617 -0400
++++ performous-1.0/game/song.hh 2015-03-31 13:56:23.609025021 -0400
+@@ -3,6 +3,7 @@
+ #include "i18n.hh"
+ #include "notes.hh"
+ #include "util.hh"
++#include "fs.hh"
+ #include <boost/foreach.hpp>
+ #include <boost/noncopyable.hpp>
+ #include <stdexcept>
diff --git a/games-arcade/performous/files/performous-1.0-libav.patch b/games-arcade/performous/files/performous-1.0-libav.patch
new file mode 100644
index 000000000000..e3f36615281e
--- /dev/null
+++ b/games-arcade/performous/files/performous-1.0-libav.patch
@@ -0,0 +1,19 @@
+diff -urN Performous-0.6.1-Source.old/cmake/Modules/FindAVUtil.cmake Performous-0.6.1-Source/cmake/Modules/FindAVUtil.cmake
+--- Performous-0.6.1-Source.old/cmake/Modules/FindAVUtil.cmake 2012-05-16 13:44:26.112930173 +0200
++++ Performous-0.6.1-Source/cmake/Modules/FindAVUtil.cmake 2012-05-16 13:56:10.229914635 +0200
+@@ -25,9 +25,15 @@
+ if(EXISTS "${AVUtil_INCLUDE_DIR}/${suffix}avutil.h")
+ set(AVUtil_INCLUDE "${suffix}avutil.h")
+ endif(EXISTS "${AVUtil_INCLUDE_DIR}/${suffix}avutil.h")
++ if(EXISTS "${AVUtil_INCLUDE_DIR}/${suffix}mathematics.h")
++ set(AVUtilMath_INCLUDE "${suffix}mathematics.h")
++ endif(EXISTS "${AVUtil_INCLUDE_DIR}/${suffix}mathematics.h")
+ endif(NOT AVUtil_INCLUDE)
+ endforeach(suffix)
+
++ if(NOT AVUtilMath_INCLUDE)
++ message(FATAL_ERROR "Found mathematics.h include dir, but not the header file. Perhaps you need to clear CMake cache?")
++ endif(NOT AVUtilMath_INCLUDE)
+ if(NOT AVUtil_INCLUDE)
+ message(FATAL_ERROR "Found avutil.h include dir, but not the header file. Perhaps you need to clear CMake cache?")
+ endif(NOT AVUtil_INCLUDE)
diff --git a/games-arcade/performous/files/performous-1.0-linguas.patch b/games-arcade/performous/files/performous-1.0-linguas.patch
new file mode 100644
index 000000000000..f8f1349ea3b9
--- /dev/null
+++ b/games-arcade/performous/files/performous-1.0-linguas.patch
@@ -0,0 +1,18 @@
+diff -ru performous-1.0.orig/lang/CMakeLists.txt performous-1.0/lang/CMakeLists.txt
+--- performous-1.0.orig/lang/CMakeLists.txt 2014-10-28 19:11:45.000000000 -0400
++++ performous-1.0/lang/CMakeLists.txt 2015-02-22 04:25:40.502252942 -0500
+@@ -9,5 +9,13 @@
+ file(MAKE_DIRECTORY "${mobuild}")
+ add_custom_command(OUTPUT "${mofile}" COMMAND "${Msgfmt_BIN}" -v "${pofile}" -o "${mofile}" MAIN_DEPENDENCY "${pofile}" COMMENT "Building ${language} locale" VERBATIM)
+ add_custom_target("locale_${language}" ALL DEPENDS "${mofile}") # Make sure the mofiles are always built
+- install(FILES "${mofile}" DESTINATION "${LOCALE_DIR}/${language}/LC_MESSAGES")
+ endforeach(language)
++foreach(language $ENV{LINGUAS})
++ set(pofile ${CMAKE_CURRENT_SOURCE_DIR}/${language}.po)
++ if (EXISTS ${pofile})
++ set(mofile ${CMAKE_CURRENT_BINARY_DIR}/${language}.mo)
++ install(FILES ${mofile} DESTINATION
++{LOCALE_DIR}/${language}/LC_MESSAGES RENAME ${CMAKE_PROJECT_NAME}.mo)
++ endif()
++endforeach(language)
++