summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-11-22 00:33:34 -0500
committerMichael Sterrett <mr_bones_@gentoo.org>2015-11-22 00:33:34 -0500
commit5fec55e7f58b85da72d67ac4dd74d273a7ae8531 (patch)
tree08581681983ff23bc316aabe4382231eef425626 /games-arcade
parentuse epatch to apply patch (diff)
downloadgentoo-5fec55e7f58b85da72d67ac4dd74d273a7ae8531.tar.gz
gentoo-5fec55e7f58b85da72d67ac4dd74d273a7ae8531.tar.bz2
gentoo-5fec55e7f58b85da72d67ac4dd74d273a7ae8531.zip
use epatch to apply patch
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/blockrage/blockrage-0.2.3.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/games-arcade/blockrage/blockrage-0.2.3.ebuild b/games-arcade/blockrage/blockrage-0.2.3.ebuild
index abe431660f4f..78dd1788ab85 100644
--- a/games-arcade/blockrage/blockrage-0.2.3.ebuild
+++ b/games-arcade/blockrage/blockrage-0.2.3.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=5
inherit eutils games
DESCRIPTION="Falling-blocks arcade game with a 2-player hotseat mode"
@@ -14,13 +14,16 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-DEPEND="media-libs/libsdl"
-RDEPEND="${DEPEND}"
+DEPEND="media-libs/libsdl[video]"
+RDEPEND=${DEPEND}
# Removing error due to wrong detection of cross-compile mode
-PATCHES=( "${FILESDIR}/${P}"-config.patch )
DOCS=( ChangeLog KNOWN_BUGS README TODO )
+src_prepare() {
+ epatch "${FILESDIR}/${P}"-config.patch
+}
+
src_install() {
default
prepgamesdirs