summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-23 20:44:24 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-23 21:17:20 +0200
commitecdf6f2ed86478134b2df76aa7f1f836dac11397 (patch)
tree02bea97ff19896512eab1270a6d967574cabab57 /games-arcade
parentgames-arcade/retrobattle: Drop old (diff)
downloadgentoo-ecdf6f2ed86478134b2df76aa7f1f836dac11397.tar.gz
gentoo-ecdf6f2ed86478134b2df76aa7f1f836dac11397.tar.bz2
gentoo-ecdf6f2ed86478134b2df76aa7f1f836dac11397.zip
games-arcade/ri-li: Stop using games.eclass
Package-Manager: Portage-2.3.31, Repoman-2.3.9
Diffstat (limited to 'games-arcade')
-rw-r--r--games-arcade/ri-li/files/ri-li-2.0.1-gcc43.patch44
-rw-r--r--games-arcade/ri-li/ri-li-2.0.1-r1.ebuild35
2 files changed, 57 insertions, 22 deletions
diff --git a/games-arcade/ri-li/files/ri-li-2.0.1-gcc43.patch b/games-arcade/ri-li/files/ri-li-2.0.1-gcc43.patch
index 7c7de0f9395d..3782627c83bd 100644
--- a/games-arcade/ri-li/files/ri-li-2.0.1-gcc43.patch
+++ b/games-arcade/ri-li/files/ri-li-2.0.1-gcc43.patch
@@ -1,5 +1,5 @@
---- src/audio.cc
-+++ src/audio.cc
+--- a/src/audio.cc
++++ b/src/audio.cc
@@ -22,7 +22,7 @@
// 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
@@ -18,8 +18,8 @@
return false;
}
---- src/ecran.cc
-+++ src/ecran.cc
+--- a/src/ecran.cc
++++ b/src/ecran.cc
@@ -21,7 +21,7 @@
// with this program; if not, write to the Free Software Foundation, Inc.,
// 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
@@ -29,8 +29,8 @@
#include <stdio.h>
#include <stdlib.h>
#include <math.h>
---- src/editeur.cc
-+++ src/editeur.cc
+--- a/src/editeur.cc
++++ b/src/editeur.cc
@@ -25,7 +25,7 @@
#include <windows.h>
#endif
@@ -49,8 +49,8 @@
exit(-1);
}
---- src/jeux.cc
-+++ src/jeux.cc
+--- a/src/jeux.cc
++++ b/src/jeux.cc
@@ -25,7 +25,7 @@
#include <windows.h>
#endif
@@ -60,8 +60,8 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
---- src/loco.cc
-+++ src/loco.cc
+--- a/src/loco.cc
++++ b/src/loco.cc
@@ -21,7 +21,7 @@
// with this program; if not, write to the Free Software Foundation, Inc.,
// 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
@@ -71,8 +71,8 @@
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
---- src/main.cc
-+++ src/main.cc
+--- a/src/main.cc
++++ b/src/main.cc
@@ -23,7 +23,7 @@
#include <stdio.h>
@@ -109,8 +109,8 @@
exit(-1);
}
// Change le nom de la fenetre
---- src/menu.cc
-+++ src/menu.cc
+--- a/src/menu.cc
++++ b/src/menu.cc
@@ -21,7 +21,7 @@
// with this program; if not, write to the Free Software Foundation, Inc.,
// 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
@@ -138,8 +138,8 @@
exit(-1);
}
---- src/mouse.cc
-+++ src/mouse.cc
+--- a/src/mouse.cc
++++ b/src/mouse.cc
@@ -21,7 +21,7 @@
// with this program; if not, write to the Free Software Foundation, Inc.,
// 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
@@ -149,8 +149,8 @@
#include <stdio.h>
#include "mouse.h"
#include "preference.h"
---- src/sprite.cc
-+++ src/sprite.cc
+--- a/src/sprite.cc
++++ b/src/sprite.cc
@@ -21,7 +21,7 @@
// with this program; if not, write to the Free Software Foundation, Inc.,
// 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
@@ -205,8 +205,8 @@
return false;
}
return true;
---- src/tableau.cc
-+++ src/tableau.cc
+--- a/src/tableau.cc
++++ b/src/tableau.cc
@@ -21,7 +21,7 @@
// with this program; if not, write to the Free Software Foundation, Inc.,
// 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
@@ -216,8 +216,8 @@
#include <stdio.h>
#include <stdlib.h>
#include "preference.h"
---- src/utils.cc
-+++ src/utils.cc
+--- a/src/utils.cc
++++ b/src/utils.cc
@@ -21,7 +21,7 @@
// with this program; if not, write to the Free Software Foundation, Inc.,
// 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
diff --git a/games-arcade/ri-li/ri-li-2.0.1-r1.ebuild b/games-arcade/ri-li/ri-li-2.0.1-r1.ebuild
new file mode 100644
index 000000000000..9fc7f0cd4a6a
--- /dev/null
+++ b/games-arcade/ri-li/ri-li-2.0.1-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools desktop
+
+DESCRIPTION="Drive a toy wood engine and collect all the coaches"
+HOMEPAGE="http://ri-li.sourceforge.net/"
+SRC_URI="mirror://sourceforge/ri-li/Ri-li-${PV}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl[sound,video]
+ media-libs/sdl-mixer[mod]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/Ri-li-${PV}"
+
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${P}-gcc43.patch
+ mv configure.{in,ac}
+ rm aclocal.m4
+ eautoreconf
+}
+
+src_install() {
+ default
+ rm -f "${ED}/usr/share/Ri-li/"*ebuild
+ newicon data/Ri-li-icon-48x48.png ${PN}.png
+ make_desktop_entry Ri_li Ri-li
+}