summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/pokerth
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/pokerth')
-rw-r--r--games-board/pokerth/Manifest1
-rw-r--r--games-board/pokerth/files/pokerth-1.1.1-underlinking.patch20
-rw-r--r--games-board/pokerth/metadata.xml8
-rw-r--r--games-board/pokerth/pokerth-1.1.1.ebuild70
4 files changed, 99 insertions, 0 deletions
diff --git a/games-board/pokerth/Manifest b/games-board/pokerth/Manifest
new file mode 100644
index 000000000000..4934c75da673
--- /dev/null
+++ b/games-board/pokerth/Manifest
@@ -0,0 +1 @@
+DIST PokerTH-1.1.1-src.tar.bz2 19326922 SHA256 afe6d3887d2fdf92fd6d89ee2951d3b14a0d43b70dba858d32d41214a5357388 SHA512 bd822d15747d94b67657ea2fd0b9c8c1bdad0031a6eae30380217387a702e5f648d6f612b1bff0355c3c301ecaf47ca9d635a526e575f1bc1c5f88e38a7f73c1 WHIRLPOOL 64fe03bbd2a4511c4d8c276cb0ee4a8f5913fe959a389578436098bd0546813d2bc47cb3ae1bcac4124a7bb843894bfce91c5e526cc66eb6912f60f98312f841
diff --git a/games-board/pokerth/files/pokerth-1.1.1-underlinking.patch b/games-board/pokerth/files/pokerth-1.1.1-underlinking.patch
new file mode 100644
index 000000000000..397fb7d6c1bc
--- /dev/null
+++ b/games-board/pokerth/files/pokerth-1.1.1-underlinking.patch
@@ -0,0 +1,20 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Thu Aug 16 22:25:12 UTC 2012
+Subject: build system
+
+fix compilation for linkers that don't permit underlinking
+reorder linker line to fix issues with as-needed
+
+--- pokerth_server.pro
++++ pokerth_server.pro
+@@ -114,8 +114,8 @@
+ LIBS += -lpokerth_lib \
+ -lpokerth_db \
+ -lpokerth_protocol \
+- -lcurl \
+- -lircclient
++ -lircclient \
++ $$system(pkg-config --libs --static libcurl)
+
+ win32 {
+ DEFINES += CURL_STATICLIB
diff --git a/games-board/pokerth/metadata.xml b/games-board/pokerth/metadata.xml
new file mode 100644
index 000000000000..9a9ac85b756c
--- /dev/null
+++ b/games-board/pokerth/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="sourceforge">pokerth</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/games-board/pokerth/pokerth-1.1.1.ebuild b/games-board/pokerth/pokerth-1.1.1.ebuild
new file mode 100644
index 000000000000..d12b3d884d8a
--- /dev/null
+++ b/games-board/pokerth/pokerth-1.1.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit flag-o-matic eutils qt4-r2 games
+
+MY_P="PokerTH-${PV}-src"
+DESCRIPTION="Texas Hold'em poker game"
+HOMEPAGE="http://www.pokerth.net/"
+SRC_URI="mirror://sourceforge/pokerth/${MY_P}.tar.bz2"
+
+LICENSE="AGPL-3 GPL-1 GPL-2 GPL-3 BitstreamVera public-domain"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="dedicated"
+
+RDEPEND="dev-db/sqlite:3
+ dev-libs/boost:=[threads(+)]
+ dev-libs/protobuf
+ dev-libs/libgcrypt:0
+ dev-libs/tinyxml[stl]
+ amd64? ( net-libs/libircclient )
+ ppc? ( >=net-libs/libircclient-1.6-r2 )
+ x86? ( net-libs/libircclient )
+ >=net-misc/curl-7.16
+ dev-qt/qtcore:4
+ virtual/gsasl
+ !dedicated? (
+ media-libs/libsdl:0
+ media-libs/sdl-mixer[mod,vorbis]
+ dev-qt/qtgui:4
+ )"
+DEPEND="${RDEPEND}
+ !dedicated? ( dev-qt/qtsql:4 )
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ if use dedicated ; then
+ sed -i \
+ -e 's/pokerth_game.pro//' \
+ pokerth.pro || die
+ fi
+
+ sed -i \
+ -e '/no_dead_strip_inits_and_terms/d' \
+ *pro || die
+
+ #epatch "${FILESDIR}"/${P}-underlinking.patch
+}
+
+src_configure() {
+ eqmake4
+}
+
+src_install() {
+ dogamesbin bin/pokerth_server
+ if ! use dedicated ; then
+ dogamesbin ${PN}
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data
+ domenu ${PN}.desktop
+ doicon ${PN}.png
+ fi
+ doman docs/pokerth.1
+ dodoc ChangeLog TODO docs/{gui_styling,server_setup}_howto.txt
+ prepgamesdirs
+}