summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-19 09:33:34 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-19 09:34:15 +0200
commitdb2118a278a6fadabc9d565225e87e92fedda8bc (patch)
treeca2088bfd1b5a42a5b3968106f6ca6324939e4bd /games-emulation/atari800
parentgames-emulation/atari800: Update the patch to work against -p1 (diff)
downloadgentoo-db2118a278a6fadabc9d565225e87e92fedda8bc.tar.gz
gentoo-db2118a278a6fadabc9d565225e87e92fedda8bc.tar.bz2
gentoo-db2118a278a6fadabc9d565225e87e92fedda8bc.zip
games-emulation/atari800: Fix some basisms in configure
Closes: https://bugs.gentoo.org/808945 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'games-emulation/atari800')
-rw-r--r--games-emulation/atari800/atari800-4.2.0-r1.ebuild2
-rw-r--r--games-emulation/atari800/files/atari800-4.2.0-bashisms.patch47
2 files changed, 49 insertions, 0 deletions
diff --git a/games-emulation/atari800/atari800-4.2.0-r1.ebuild b/games-emulation/atari800/atari800-4.2.0-r1.ebuild
index 7e1194869885..25d867bd8214 100644
--- a/games-emulation/atari800/atari800-4.2.0-r1.ebuild
+++ b/games-emulation/atari800/atari800-4.2.0-r1.ebuild
@@ -40,6 +40,8 @@ src_prepare() {
local PATCHES=(
# Bug 544608
"${FILESDIR}"/atari800-3.1.0-tgetent-detection.patch
+ # https://github.com/atari800/atari800/pull/140
+ "${FILESDIR}"/${P}-bashisms.patch
)
default
diff --git a/games-emulation/atari800/files/atari800-4.2.0-bashisms.patch b/games-emulation/atari800/files/atari800-4.2.0-bashisms.patch
new file mode 100644
index 000000000000..117bf1feee86
--- /dev/null
+++ b/games-emulation/atari800/files/atari800-4.2.0-bashisms.patch
@@ -0,0 +1,47 @@
+From 92b1d0d2ea8cc87bf6a9b9084aa76ca3580d5e4e Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
+Date: Thu, 19 Aug 2021 09:26:41 +0200
+Subject: [PATCH] configure.ac: Fix compatibility with dash shell
+
+Fix the compatibility of the configure script with the dash shell
+by replacing the use of bash-specific '==' operator with plain '='.
+The calls in question do not utilize the pattern-matching behavior
+of '=='.
+---
+ configure.ac | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index c872a9b3..283c90e2 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -709,7 +709,7 @@ AC_DEFUN([A8_OPTION],[
+ fi
+ ])
+
+-if [[ "$a8_target" == "libatari800" ]]; then
++if [[ "$a8_target" = "libatari800" ]]; then
+ WANT_NEW_CYCLE_EXACT=yes
+ WANT_VERY_SLOW=no
+ WANT_CRASH_MENU=no
+@@ -1040,7 +1040,7 @@ if [[ "$with_sound" != no ]]; then
+ VOICEBOX,[Define to emulate the Alien Group Voice Box.]
+ )
+
+- if [[ "$with_sound" == "libatari800" ]]; then
++ if [[ "$with_sound" = "libatari800" ]]; then
+ WANT_SOUND_CALLBACK=no
+ WANT_CONSOLE_SOUND=yes
+ WANT_SERIO_SOUND=yes
+@@ -1094,7 +1094,7 @@ A8_OPTION(pokeyrec,$WANT_POKEYREC,
+ [Provide Pokey registers recording (default=ON)],
+ POKEYREC,[Define to add Pokey registers recording.]
+ )
+-if [[ "$WANT_POKEYREC" == "yes" ]]; then
++if [[ "$WANT_POKEYREC" = "yes" ]]; then
+ AC_SYS_LARGEFILE
+ fi
+ AM_CONDITIONAL([WANT_POKEYREC], test "$WANT_POKEYREC" = "yes")
+--
+2.33.0
+