summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-04-22 23:21:34 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-04-22 23:33:22 -0400
commit601039b9ab17b4ee94fedf6289d1050b7de33b7e (patch)
tree3b6861580ac22199a595724b035e1d4b05258107 /games-emulation
parentnet-dialup/freeradius: fix UnusedLocalUse (diff)
downloadgentoo-601039b9ab17b4ee94fedf6289d1050b7de33b7e.tar.gz
gentoo-601039b9ab17b4ee94fedf6289d1050b7de33b7e.tar.bz2
gentoo-601039b9ab17b4ee94fedf6289d1050b7de33b7e.zip
games-emulation/higan: fix build w/ gcc13 + update deps
Doesn't overly need a revbump for the fix, but it's an excuse to replace the mostly deprecated deps at same time. Thankfully trivial considering that upstream is still inactive, imagine this will break in a worse way sooner or later. Closes: https://bugs.gentoo.org/898898 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/higan/files/higan-116_pre20210818-gcc13.patch7
-rw-r--r--games-emulation/higan/higan-116_pre20210818-r2.ebuild (renamed from games-emulation/higan/higan-116_pre20210818-r1.ebuild)7
2 files changed, 11 insertions, 3 deletions
diff --git a/games-emulation/higan/files/higan-116_pre20210818-gcc13.patch b/games-emulation/higan/files/higan-116_pre20210818-gcc13.patch
new file mode 100644
index 000000000000..8e55894b521f
--- /dev/null
+++ b/games-emulation/higan/files/higan-116_pre20210818-gcc13.patch
@@ -0,0 +1,7 @@
+https://bugs.gentoo.org/898898
+--- a/nall/arithmetic/natural.hpp
++++ b/nall/arithmetic/natural.hpp
+@@ -1 +1,3 @@
++#include <stdexcept>
++
+ #define ConcatenateType(Size) uint##Size##_t
diff --git a/games-emulation/higan/higan-116_pre20210818-r1.ebuild b/games-emulation/higan/higan-116_pre20210818-r2.ebuild
index a839c1ef8e50..79950540ab17 100644
--- a/games-emulation/higan/higan-116_pre20210818-r1.ebuild
+++ b/games-emulation/higan/higan-116_pre20210818-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -24,8 +24,8 @@ RDEPEND="
alsa? ( media-libs/alsa-lib )
ao? ( media-libs/libao )
openal? ( media-libs/openal )
- opengl? ( virtual/opengl )
- pulseaudio? ( media-sound/pulseaudio )
+ opengl? ( media-libs/libglvnd[X] )
+ pulseaudio? ( media-libs/libpulse )
sdl? ( media-libs/libsdl2[joystick] )
udev? ( virtual/libudev:= )
xv? ( x11-libs/libXv )
@@ -51,6 +51,7 @@ PATCHES=(
# insane build system, reinvents every built-in rule
"${FILESDIR}"/${PN}-116_pre20210404-makefile.patch
"${FILESDIR}"/${PN}-116_pre20210818-paths.patch
+ "${FILESDIR}"/${PN}-116_pre20210818-gcc13.patch
)
src_prepare() {