summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-03-26 15:15:25 +0100
committerLars Wendler <polynomial-c@gentoo.org>2019-03-26 15:15:44 +0100
commit3cfcb55139d4d882efa2cbc9143169c9ebec58d2 (patch)
tree765a7382d62673ecb1d9e6eaeb4b5d480211b695 /games-misc/opengfx/opengfx-0.5.5.ebuild
parentsec-policy: Release of SELinux policies 2.20190201-r1 (diff)
downloadgentoo-3cfcb55139d4d882efa2cbc9143169c9ebec58d2.tar.gz
gentoo-3cfcb55139d4d882efa2cbc9143169c9ebec58d2.tar.bz2
gentoo-3cfcb55139d4d882efa2cbc9143169c9ebec58d2.zip
games-misc/opengfx: Bump to version 0.5.5
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'games-misc/opengfx/opengfx-0.5.5.ebuild')
-rw-r--r--games-misc/opengfx/opengfx-0.5.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/games-misc/opengfx/opengfx-0.5.5.ebuild b/games-misc/opengfx/opengfx-0.5.5.ebuild
new file mode 100644
index 000000000000..dc39acc0d275
--- /dev/null
+++ b/games-misc/opengfx/opengfx-0.5.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="OpenGFX data files for OpenTTD"
+HOMEPAGE="http://bundles.openttdcoop.org/opengfx/"
+SRC_URI="http://bundles.openttdcoop.org/opengfx/releases/${PV}/${P}-source.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+RESTRICT="test" # nml version affects the checksums that the test uses (bug #451444)
+
+DEPEND=">=games-util/nml-0.4.0
+ games-util/grfcodec"
+RDEPEND=""
+
+S="${WORKDIR}/${P}-source"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.5.5-Makefile.patch"
+)
+
+src_compile() {
+ emake GIMP="" help # print out the env to make bug reports better
+ emake GIMP="" _V="" bundle_tar
+}
+
+src_install() {
+ insinto "/usr/share/games/openttd/data/"
+ doins *.grf opengfx.obg
+ dodoc docs/{changelog.txt,readme.txt}
+}