summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErik Mackdanz <stasibear@gentoo.org>2021-12-30 09:43:31 -0600
committerErik Mackdanz <stasibear@gentoo.org>2021-12-30 09:43:31 -0600
commit2aa8bfe8b2baece61b41e2b3b14798b41b6fbe6b (patch)
tree40e29d86707a28cfb8522baeb5e5b39d03598ed7 /games-roguelike/stone-soup
parentdev-lang/php: Version bump for 8.1.1 (diff)
downloadgentoo-2aa8bfe8b2baece61b41e2b3b14798b41b6fbe6b.tar.gz
gentoo-2aa8bfe8b2baece61b41e2b3b14798b41b6fbe6b.tar.bz2
gentoo-2aa8bfe8b2baece61b41e2b3b14798b41b6fbe6b.zip
games-roguelike/stone-soup: use system dev-cpp/catch for tests
... not the bundled one Closes: https://bugs.gentoo.org/829950 Signed-off-by: Erik Mackdanz <stasibear@gentoo.org> Package-Manager: Portage-3.0.28, Repoman-3.0.3
Diffstat (limited to 'games-roguelike/stone-soup')
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.25.1-r102.ebuild9
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.26.1-r1.ebuild9
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.27.1.ebuild9
-rw-r--r--games-roguelike/stone-soup/stone-soup-0.28.0_pre20211224.ebuild9
4 files changed, 32 insertions, 4 deletions
diff --git a/games-roguelike/stone-soup/stone-soup-0.25.1-r102.ebuild b/games-roguelike/stone-soup/stone-soup-0.25.1-r102.ebuild
index de7a56e16eed..1d7ea744c044 100644
--- a/games-roguelike/stone-soup/stone-soup-0.25.1-r102.ebuild
+++ b/games-roguelike/stone-soup/stone-soup-0.25.1-r102.ebuild
@@ -24,7 +24,7 @@ SRC_URI="
# MIT: json.cc/json.h, some .js files in webserver/static/scripts/contrib/
LICENSE="GPL-2 BSD BSD-2 public-domain CC0-1.0 MIT"
KEYWORDS="amd64 x86"
-IUSE="debug ncurses sound +tiles"
+IUSE="debug ncurses sound test +tiles"
RDEPEND="
${LUA_DEPS}
@@ -51,6 +51,7 @@ DEPEND="${RDEPEND}
${PYTHON_DEPS}
$(python_gen_any_dep 'dev-python/pyyaml[${PYTHON_USEDEP}]')
sys-devel/flex
+ test? ( dev-cpp/catch:0 )
tiles? (
media-gfx/pngcrush
sys-libs/ncurses:0
@@ -90,6 +91,12 @@ src_prepare() {
sed -i -e "s/GAME = crawl$/GAME = crawl-${SLOT}/" "${S}/Makefile" \
|| die "Couldn't append slot to executable name"
+
+ # Replace bundled catch2 package with system implementation
+ # https://bugs.gentoo.org/829950
+ if use test; then
+ cp /usr/include/catch2/catch.hpp "${S}/catch2-tests" || die "Couldn't substitute system catch2"
+ fi
}
src_compile() {
diff --git a/games-roguelike/stone-soup/stone-soup-0.26.1-r1.ebuild b/games-roguelike/stone-soup/stone-soup-0.26.1-r1.ebuild
index 89e1c7c44b5b..dc9525094429 100644
--- a/games-roguelike/stone-soup/stone-soup-0.26.1-r1.ebuild
+++ b/games-roguelike/stone-soup/stone-soup-0.26.1-r1.ebuild
@@ -24,7 +24,7 @@ SRC_URI="
# MIT: json.cc/json.h, some .js files in webserver/static/scripts/contrib/
LICENSE="GPL-2 BSD BSD-2 public-domain CC0-1.0 MIT"
KEYWORDS="amd64 x86"
-IUSE="debug ncurses sound +tiles"
+IUSE="debug ncurses sound test +tiles"
RDEPEND="
${LUA_DEPS}
@@ -51,6 +51,7 @@ DEPEND="${RDEPEND}
${PYTHON_DEPS}
$(python_gen_any_dep 'dev-python/pyyaml[${PYTHON_USEDEP}]')
sys-devel/flex
+ test? ( dev-cpp/catch:0 )
tiles? (
media-gfx/pngcrush
sys-libs/ncurses:0
@@ -90,6 +91,12 @@ src_prepare() {
sed -i -e "s/GAME = crawl$/GAME = crawl-${SLOT}/" "${S}/Makefile" \
|| die "Couldn't append slot to executable name"
+
+ # Replace bundled catch2 package with system implementation
+ # https://bugs.gentoo.org/829950
+ if use test; then
+ cp /usr/include/catch2/catch.hpp "${S}/catch2-tests" || die "Couldn't substitute system catch2"
+ fi
}
src_compile() {
diff --git a/games-roguelike/stone-soup/stone-soup-0.27.1.ebuild b/games-roguelike/stone-soup/stone-soup-0.27.1.ebuild
index 2c294df13dba..29c7f43de73a 100644
--- a/games-roguelike/stone-soup/stone-soup-0.27.1.ebuild
+++ b/games-roguelike/stone-soup/stone-soup-0.27.1.ebuild
@@ -24,7 +24,7 @@ SRC_URI="
# MIT: json.cc/json.h, some .js files in webserver/static/scripts/contrib/
LICENSE="GPL-2 BSD BSD-2 public-domain CC0-1.0 MIT"
KEYWORDS="amd64 x86"
-IUSE="debug ncurses sound +tiles"
+IUSE="debug ncurses sound test +tiles"
RDEPEND="
${LUA_DEPS}
@@ -51,6 +51,7 @@ DEPEND="${RDEPEND}
${PYTHON_DEPS}
$(python_gen_any_dep 'dev-python/pyyaml[${PYTHON_USEDEP}]')
sys-devel/flex
+ test? ( dev-cpp/catch:0 )
tiles? (
media-gfx/pngcrush
sys-libs/ncurses:0
@@ -90,6 +91,12 @@ src_prepare() {
sed -i -e "s/GAME = crawl$/GAME = crawl-${SLOT}/" "${S}/Makefile" \
|| die "Couldn't append slot to executable name"
+
+ # Replace bundled catch2 package with system implementation
+ # https://bugs.gentoo.org/829950
+ if use test; then
+ cp /usr/include/catch2/catch.hpp "${S}/catch2-tests" || die "Couldn't substitute system catch2"
+ fi
}
src_compile() {
diff --git a/games-roguelike/stone-soup/stone-soup-0.28.0_pre20211224.ebuild b/games-roguelike/stone-soup/stone-soup-0.28.0_pre20211224.ebuild
index 8a19eb39dc41..76eb66818392 100644
--- a/games-roguelike/stone-soup/stone-soup-0.28.0_pre20211224.ebuild
+++ b/games-roguelike/stone-soup/stone-soup-0.28.0_pre20211224.ebuild
@@ -38,7 +38,7 @@ fi
# MIT: json.cc/json.h, some .js files in webserver/static/scripts/contrib/
LICENSE="GPL-2 BSD BSD-2 public-domain CC0-1.0 MIT"
KEYWORDS="~amd64 ~x86"
-IUSE="debug ncurses sound +tiles"
+IUSE="debug ncurses sound test +tiles"
S=${WORKDIR}/${MY_P}/source
RDEPEND="
@@ -66,6 +66,7 @@ DEPEND="${RDEPEND}
${PYTHON_DEPS}
$(python_gen_any_dep 'dev-python/pyyaml[${PYTHON_USEDEP}]')
sys-devel/flex
+ test? ( dev-cpp/catch:0 )
tiles? (
media-gfx/pngcrush
sys-libs/ncurses:0
@@ -109,6 +110,12 @@ src_prepare() {
if ! [ -f "${S}/util/release_ver" ]; then
echo "${SLOT}" >"${S}/util/release_ver" || die "Couldn't write release_ver"
fi
+
+ # Replace bundled catch2 package with system implementation
+ # https://bugs.gentoo.org/829950
+ if use test; then
+ cp /usr/include/catch2/catch.hpp "${S}/catch2-tests" || die "Couldn't substitute system catch2"
+ fi
}
src_compile() {