summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-12-01 23:39:04 +0100
committerMarek Szuba <marecki@gentoo.org>2020-12-01 23:53:53 +0100
commit2e1834613e434ec0700d888a7c63bf53da39903b (patch)
tree6af885f87bf4342febb3e884cc2f28de5de562b9 /games-strategy/naev
parentgames-strategy/naev: update to 0.7.0 (diff)
downloadgentoo-2e1834613e434ec0700d888a7c63bf53da39903b.tar.gz
gentoo-2e1834613e434ec0700d888a7c63bf53da39903b.tar.bz2
gentoo-2e1834613e434ec0700d888a7c63bf53da39903b.zip
games-strategy/naev-0.7.0: fix SRC_URI, explain BDEPEND/src_unpack
pkgcheck complains about the lack of app-arch/unzip in BDEPEND but that is not correct - the data file is supposed to be installed zipped, and the custom src_unpack ensures only the source tarball is actually unpacked. Add a comment explaining this. More importantly, both SRC_URI wrong had '/${P}/' where '/v${PV}/' should be according to the layout of GitHub upstream as of 5 minutes ago. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'games-strategy/naev')
-rw-r--r--games-strategy/naev/naev-0.7.0.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/games-strategy/naev/naev-0.7.0.ebuild b/games-strategy/naev/naev-0.7.0.ebuild
index 20d6fd69fb52..1b20e968fdde 100644
--- a/games-strategy/naev/naev-0.7.0.ebuild
+++ b/games-strategy/naev/naev-0.7.0.ebuild
@@ -2,12 +2,13 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit xdg-utils
DESCRIPTION="A 2D space trading and combat game, in a similar vein to Escape Velocity"
HOMEPAGE="https://naev.org/ https://github.com/naev/naev"
-SRC_URI="https://github.com/naev/naev/releases/download/${P}/${P}.tar.bz2
- https://github.com/naev/naev/releases/download/${P}/${P}-ndata.zip"
+SRC_URI="https://github.com/naev/naev/releases/download/v${PV}/${P}.tar.bz2
+ https://github.com/naev/naev/releases/download/v${PV}/${P}-ndata.zip"
LICENSE="GPL-2 GPL-3 public-domain CC-BY-3.0 CC-BY-SA-3.0"
SLOT="0"
@@ -30,6 +31,9 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
+# This is so that only the source tarball is unpacked - the data file
+# is supposed to be installed *zipped*. This is why we do not need unzip
+# in BDEPEND in spite of what repoman/pkgcheck might say.
src_unpack() {
unpack ${P}.tar.bz2
}