summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-12-23 23:23:49 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-12-24 01:13:06 -0500
commit8a12c556899160652b35a7f4665a647a7896cd76 (patch)
treef47de6c6a00f0d733ea6c19946fd0fa94d4acf3c /games-strategy
parentdev-libs/nativefiledialog-extended: new package, add 1.2.1 (diff)
downloadgentoo-8a12c556899160652b35a7f4665a647a7896cd76.tar.gz
gentoo-8a12c556899160652b35a7f4665a647a7896cd76.tar.bz2
gentoo-8a12c556899160652b35a7f4665a647a7896cd76.zip
games-strategy/naev: restrict tests
This broke (again) with software rendering likely since some mesa or Xorg version but unsure (fails to create opengl context), could also be missing something new for this to work. At this point would rather just restrict it than try to figure out what went wrong every time, esp. since always been doing the same test manually anyway. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/naev/naev-0.11.5.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/games-strategy/naev/naev-0.11.5.ebuild b/games-strategy/naev/naev-0.11.5.ebuild
index b15834855402..da1c44d6a2ad 100644
--- a/games-strategy/naev/naev-0.11.5.ebuild
+++ b/games-strategy/naev/naev-0.11.5.ebuild
@@ -21,6 +21,11 @@ KEYWORDS="~amd64 ~x86"
IUSE="doc"
REQUIRED_USE="${LUA_REQUIRED_USE}"
+# tests are very basic, equivalent of just starting the game and checking if
+# can see the main menu -- but this breaks easily with software rendering and
+# some Xorg/mesa versions, simpler to do manually than try to keep this working
+RESTRICT="test"
+
# dlopen: libglvnd
RDEPEND="
${LUA_DEPS}
@@ -78,8 +83,7 @@ src_prepare() {
# use eclass' generated lua.pc first rather than as fallback
sed -i "s/'lua51'/'lua'/" meson.build || die
- # don't probe OpenGL for tests (avoids sandbox violations, bug #829369),
- # mesa[llvm] should ensure software rendering will work
+ # don't probe OpenGL for tests (avoids sandbox violations, bug #829369)
sed -i "/subdir('glcheck')/d" test/meson.build || die
}