summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-11-12 14:43:47 -0500
committerMike Gilbert <floppym@gentoo.org>2021-11-12 14:44:36 -0500
commit1106846c19996c2273d25bf4a1bd7ff27e470e68 (patch)
treecd17317e562232aabfd33dc0584b8ff2b000f062 /gnome-base
parentdev-lang/rust-bin: don't inherit bash-completion-r1 in 1.56.1 (diff)
downloadgentoo-1106846c19996c2273d25bf4a1bd7ff27e470e68.tar.gz
gentoo-1106846c19996c2273d25bf4a1bd7ff27e470e68.tar.bz2
gentoo-1106846c19996c2273d25bf4a1bd7ff27e470e68.zip
gnome-base/gnome-settings-daemon: backport meson fix
Closes: https://bugs.gentoo.org/823134 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-40.0.1-build-fix-str-bool-comparison.patch29
-rw-r--r--gnome-base/gnome-settings-daemon/gnome-settings-daemon-40.0.1.ebuild1
2 files changed, 30 insertions, 0 deletions
diff --git a/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-40.0.1-build-fix-str-bool-comparison.patch b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-40.0.1-build-fix-str-bool-comparison.patch
new file mode 100644
index 000000000000..19cb682ca296
--- /dev/null
+++ b/gnome-base/gnome-settings-daemon/files/gnome-settings-daemon-40.0.1-build-fix-str-bool-comparison.patch
@@ -0,0 +1,29 @@
+From 28e28e9e598342c897ae5ca350d0da6f4aea057b Mon Sep 17 00:00:00 2001
+From: Bastien Nocera <hadess@hadess.net>
+Date: Fri, 16 Jul 2021 16:02:36 +0200
+Subject: [PATCH] build: Fix str/bool comparison
+
+gnome-settings-daemon/meson.build:87: WARNING: Trying to compare values of different types (str, bool) using ==.
+The result of this is undefined and will become a hard error in a future Meson release.
+---
+ meson.build | 4 +---
+ 1 file changed, 1 insertion(+), 3 deletions(-)
+
+diff --git a/meson.build b/meson.build
+index fdf71713..ba2a90ca 100644
+--- a/meson.build
++++ b/meson.build
+@@ -82,9 +82,7 @@ elif gsd_buildtype.contains('release')
+ common_flags += ['-DG_DISABLE_CAST_CHECKS']
+ endif
+
+-# Workaround for meson's bug
+-# https://github.com/mesonbuild/meson/pull/1896
+-if get_option('b_ndebug') == true
++if get_option('b_ndebug') == 'true'
+ common_flags += ['-DG_DISABLE_ASSERT']
+ endif
+
+--
+GitLab
+
diff --git a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-40.0.1.ebuild b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-40.0.1.ebuild
index 199826b093c4..d0b070e0d12d 100644
--- a/gnome-base/gnome-settings-daemon/gnome-settings-daemon-40.0.1.ebuild
+++ b/gnome-base/gnome-settings-daemon/gnome-settings-daemon-40.0.1.ebuild
@@ -93,6 +93,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-3.38.1-build-Make-colord-and-wacom-optional-and-controllabl.patch
"${FILESDIR}"/${PN}-3.38.1-build-Allow-NM-optional-on-Linux.patch
"${FILESDIR}"/${PN}-3.38.1-Allow-udev-optional-on-Linux.patch
+ "${FILESDIR}"/gnome-settings-daemon-40.0.1-build-fix-str-bool-comparison.patch
)
python_check_deps() {