summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKristian Fiskerstrand <k_f@gentoo.org>2018-07-04 12:50:25 +0200
committerKristian Fiskerstrand <k_f@gentoo.org>2018-07-31 10:34:34 +0200
commit5d52e7fbd962e0ba8154088e4604c1b82cc3374b (patch)
treeafba69bcb98640a9dc53640c52b064d40cb004a9 /gnome-extra/cinnamon-menus/cinnamon-menus-3.8.2.ebuild
parentgnome-extra/cinnamon-desktop: New upstream version 3.8.1 (diff)
downloadgentoo-5d52e7fbd962e0ba8154088e4604c1b82cc3374b.tar.gz
gentoo-5d52e7fbd962e0ba8154088e4604c1b82cc3374b.tar.bz2
gentoo-5d52e7fbd962e0ba8154088e4604c1b82cc3374b.zip
gnome-extra/cinnamon-menus: New upstream version 3.8.2
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'gnome-extra/cinnamon-menus/cinnamon-menus-3.8.2.ebuild')
-rw-r--r--gnome-extra/cinnamon-menus/cinnamon-menus-3.8.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnome-extra/cinnamon-menus/cinnamon-menus-3.8.2.ebuild b/gnome-extra/cinnamon-menus/cinnamon-menus-3.8.2.ebuild
new file mode 100644
index 000000000000..35270ece27e1
--- /dev/null
+++ b/gnome-extra/cinnamon-menus/cinnamon-menus-3.8.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools gnome2
+
+DESCRIPTION="Cinnamon's library for the Desktop Menu fd.o specification"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/cinnamon-menus/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +introspection"
+
+RDEPEND="
+ >=dev-libs/glib-2.29.15:2
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+"
+DEPEND="${RDEPEND}
+ dev-libs/gobject-introspection-common
+ >=dev-util/intltool-0.40
+ gnome-base/gnome-common
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(usex debug --enable-debug=yes ' ') \
+ $(use_enable introspection) \
+ --disable-static
+}