summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-extra/cinnamon-translations/cinnamon-translations-2.4.4.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-extra/cinnamon-translations/cinnamon-translations-2.4.4.ebuild')
-rw-r--r--gnome-extra/cinnamon-translations/cinnamon-translations-2.4.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnome-extra/cinnamon-translations/cinnamon-translations-2.4.4.ebuild b/gnome-extra/cinnamon-translations/cinnamon-translations-2.4.4.ebuild
new file mode 100644
index 000000000000..6ed65690553d
--- /dev/null
+++ b/gnome-extra/cinnamon-translations/cinnamon-translations-2.4.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PLOCALES="af am an ar as ast az be be@latin bg bn bn_IN br bs ca ca@valencia crh cs csb cy da de dz el en@shaw en_AU en_CA en_GB eo es es_AR et eu fa fi fil fo fr fr_CA fy ga gd gl gu he hi hr hu hy ia id is it ja jv ka kk km kn ko ksw ku ky la li lo lt lv mai mg mk ml mn mr ms my nb nds ne nl nn nso oc om or pa pl ps pt pt_BR ro ru rue rw shn si sk sl so sq sr sr@ijekavianlatin sr@latin sv ta te tg th tl tlh tpi tr ts ug uk ur uz uz@cyrillic vi wa xh yi zh_CN zh_HK zh_TW zu"
+
+inherit eutils l10n
+
+DESCRIPTION="Translation data for Cinnamon"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/cinnamon-translations/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+RESTRICT="test" # tests are for upstream translators and need network access
+
+src_prepare() {
+ epatch_user
+}
+
+src_configure() { :; }
+
+src_install() {
+ # Cannot run before since locales are not in the expected place for this to work
+ l10n_find_plocales_changes "${S}"/usr/share/locale "" ""
+
+ install_locale() {
+ dodir /usr/share/locale
+ insinto /usr/share/locale
+ doins -r usr/share/locale/${1}
+ }
+ l10n_for_each_locale_do install_locale
+}