summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-23 19:26:11 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-23 19:26:11 -0700
commite5b4feb3e854687e20856aa0c23c0ba9c358f6ab (patch)
tree1eff414a635fcf9c4e62f3fdf2d36c412ed429d3 /gnome-extra/gnome-user-docs/gnome-user-docs-42.0.ebuild
parentmedia-gfx/eog: Version bump to 42.0 (diff)
downloadgentoo-e5b4feb3e854687e20856aa0c23c0ba9c358f6ab.tar.gz
gentoo-e5b4feb3e854687e20856aa0c23c0ba9c358f6ab.tar.bz2
gentoo-e5b4feb3e854687e20856aa0c23c0ba9c358f6ab.zip
gnome-extra/gnome-user-docs: Version bump to 42.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-user-docs/gnome-user-docs-42.0.ebuild')
-rw-r--r--gnome-extra/gnome-user-docs/gnome-user-docs-42.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnome-extra/gnome-user-docs/gnome-user-docs-42.0.ebuild b/gnome-extra/gnome-user-docs/gnome-user-docs-42.0.ebuild
new file mode 100644
index 000000000000..889d05a30d13
--- /dev/null
+++ b/gnome-extra/gnome-user-docs/gnome-user-docs-42.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2
+
+DESCRIPTION="GNOME end user documentation"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-user-docs"
+
+LICENSE="CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="test"
+
+BDEPEND="test? ( dev-libs/libxml2 )"
+# eautoreconf requires:
+# app-text/yelp-tools
+# rebuilding translations requires:
+# app-text/yelp-tools
+# dev-util/gettext
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip
+ !test? ( test )"
+
+src_configure() {
+ # itstool is only needed for rebuilding translations
+ # xmllint is only needed for tests
+ gnome2_src_configure \
+ $(usex test "" XMLLINT=$(type -P true)) \
+ ITSTOOL=$(type -P true)
+}
+
+src_compile() {
+ # Do not compile; "make all" with unset LINGUAS rebuilds all translations,
+ # which can take > 2 hours on a Core i7.
+ return
+}