summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-09-13 22:31:59 -0400
committerMatt Turner <mattst88@gentoo.org>2023-09-13 23:05:51 -0400
commita9da665f81cd033236a3b2795ce01a5e170aa15c (patch)
tree26a5def87fadf134300ab0689cd3647724dc4c63 /gnome-extra/gucharmap
parentapp-i18n/unicode-data: Version bump to 15.1.0 (diff)
downloadgentoo-a9da665f81cd033236a3b2795ce01a5e170aa15c.tar.gz
gentoo-a9da665f81cd033236a3b2795ce01a5e170aa15c.tar.bz2
gentoo-a9da665f81cd033236a3b2795ce01a5e170aa15c.zip
gnome-extra/gucharmap: Version bump to 15.1.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/gucharmap')
-rw-r--r--gnome-extra/gucharmap/Manifest1
-rw-r--r--gnome-extra/gucharmap/gucharmap-15.1.0.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/gnome-extra/gucharmap/Manifest b/gnome-extra/gucharmap/Manifest
index 95254c7171ff..81e82559b5a0 100644
--- a/gnome-extra/gucharmap/Manifest
+++ b/gnome-extra/gucharmap/Manifest
@@ -1 +1,2 @@
DIST gucharmap-15.0.4.tar.bz2 1453197 BLAKE2B 718890e466e19934b012a79deefc2174edba6de59bd9a374dee5e8cf396fd0a06ae8e4db4cfb223d43284d59be87344310e4cb94e1e45ae158e0213e7bfa06f5 SHA512 280fb164f2d850f9b4a8e54c24d0bc461e0abe2e53f34a6f2f0098397c04856091c6f730cfa9451de5b676b569e2a43bcf2a9dfe160f916b00622ec5535c1e94
+DIST gucharmap-15.1.0.tar.bz2 1455091 BLAKE2B c8ca3f5aae97e0d0c10aa73559a2eae06ff2e2a9fe59186388c03d0d2c75a9f2bcafa21d1a894d25ff6cb254c9f34e7b8b5241182d05c9c9dbebbeda94078525 SHA512 b40b15592d8ed059337abf166d71eb7c315f87dcfe2c2029ab380a67b928c14aac49c63b91f99ba45cb13b6faeb8bf70ca7a19896221f2b08dfa6fb6445c0198
diff --git a/gnome-extra/gucharmap/gucharmap-15.1.0.ebuild b/gnome-extra/gucharmap/gucharmap-15.1.0.ebuild
new file mode 100644
index 000000000000..5eaba63f4112
--- /dev/null
+++ b/gnome-extra/gucharmap/gucharmap-15.1.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Unicode character map viewer and library"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gucharmap"
+SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="2.90"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+UNICODE_VERSION="15.1.0"
+
+IUSE="+introspection gtk-doc vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="media-libs/freetype:2
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=dev-libs/libpcre2-10.21:=
+ =app-i18n/unicode-data-${UNICODE_VERSION}*
+ >=x11-libs/pango-1.42.4-r2[introspection?]
+
+ !gnome-extra/gucharmap:0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ app-text/docbook-xml-dtd:4.1.2
+ dev-libs/glib:2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ gtk-doc? ( >=dev-util/gtk-doc-1 )
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+ vala? ( $(vala_depend) )
+"
+
+PATCHES=(
+ "${FILESDIR}"/14.0.1-install-user-help.patch
+)
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dcharmap=true
+ -Ddbg=false # in 14.0.1 all this does is pass -ggdb3
+ $(meson_use gtk-doc docs)
+ $(meson_use introspection gir)
+ -Dgtk3=true
+ -Ducd_path="${EPREFIX}/usr/share/unicode-data"
+ $(meson_use vala vapi)
+ )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}