summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-10-14 14:40:38 +0200
committerJeroen Roovers <jer@gentoo.org>2018-10-14 14:46:41 +0200
commit3a111ec801447789eeb4b4309a568a849dda0534 (patch)
treef8e8686a8984bb0cb6e6acd290a21ad890e9f8f9 /gnome-extra/synapse/synapse-0.2.99.4.ebuild
parentdev-perl/Test-Requires: mark s390 stable (diff)
downloadgentoo-3a111ec801447789eeb4b4309a568a849dda0534.tar.gz
gentoo-3a111ec801447789eeb4b4309a568a849dda0534.tar.bz2
gentoo-3a111ec801447789eeb4b4309a568a849dda0534.zip
gnome-extra/synapse: Version 0.2.99.4
Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'gnome-extra/synapse/synapse-0.2.99.4.ebuild')
-rw-r--r--gnome-extra/synapse/synapse-0.2.99.4.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnome-extra/synapse/synapse-0.2.99.4.ebuild b/gnome-extra/synapse/synapse-0.2.99.4.ebuild
new file mode 100644
index 000000000000..2340f03e4609
--- /dev/null
+++ b/gnome-extra/synapse/synapse-0.2.99.4.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vala
+
+DESCRIPTION="A program launcher in the style of GNOME Do"
+HOMEPAGE="https://launchpad.net/synapse-project/"
+SRC_URI="https://launchpad.net/synapse-project/0.3/${PV}/+download/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls plugins"
+
+RDEPEND="
+ >=dev-libs/glib-2.28.0:2
+ >=x11-libs/gtk+-3.0.0:3
+ dev-libs/json-glib
+ dev-libs/keybinder:3
+ dev-libs/libgee:0.8
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/libnotify
+ x11-libs/pango
+ x11-themes/adwaita-icon-theme
+ nls? ( virtual/libintl )
+ plugins? ( >=net-libs/rest-0.7 )
+"
+DEPEND="
+ $(vala_depend)
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+ sed -i -e 's/GNOME/GNOME;GTK/' data/synapse.desktop.in || die
+ vala_src_prepare
+}
+
+src_configure() {
+ econf \
+ $(use_enable plugins librest yes) \
+ $(use_enable nls) \
+ --disable-zeitgeist \
+ --enable-indicator=no
+}