summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-04-02 15:14:35 +0200
committerPacho Ramos <pacho@gentoo.org>2016-04-02 15:15:37 +0200
commit33f06a2f55dd58ae723164e8bdb2362250e3972d (patch)
treeb4325175808e44313f5a462c83735f190c14df69 /gnome-extra
parentdev-perl/Module-Signature: amd64/x86 stable, (ALLARCHES policy) wrt bug #578464 (diff)
downloadgentoo-33f06a2f55dd58ae723164e8bdb2362250e3972d.tar.gz
gentoo-33f06a2f55dd58ae723164e8bdb2362250e3972d.tar.bz2
gentoo-33f06a2f55dd58ae723164e8bdb2362250e3972d.zip
gnome-extra/gnome-tweak-tool: Stop relying on libsoup-gnome
Package-Manager: portage-2.2.28
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-tweak-tool/files/gnome-tweak-tool-3.18.1-libsoup.patch41
-rw-r--r--gnome-extra/gnome-tweak-tool/gnome-tweak-tool-3.18.1-r2.ebuild78
2 files changed, 119 insertions, 0 deletions
diff --git a/gnome-extra/gnome-tweak-tool/files/gnome-tweak-tool-3.18.1-libsoup.patch b/gnome-extra/gnome-tweak-tool/files/gnome-tweak-tool-3.18.1-libsoup.patch
new file mode 100644
index 000000000000..16aac1279c2e
--- /dev/null
+++ b/gnome-extra/gnome-tweak-tool/files/gnome-tweak-tool-3.18.1-libsoup.patch
@@ -0,0 +1,41 @@
+From 0335e0edd652542ab6b995dc3e4334251b582b5d Mon Sep 17 00:00:00 2001
+From: Rui Matos <tiagomatos@gmail.com>
+Date: Sun, 17 Jan 2016 19:48:51 +0100
+Subject: egowrapper: Port to new Soup.Session API
+
+This also allows us to stop using SoupGNOME since Soup.Session now
+uses the system's default proxy by default.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=759951
+---
+ gtweak/egowrapper.py | 6 ++----
+ 1 file changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/gtweak/egowrapper.py b/gtweak/egowrapper.py
+index 738172a..9657c9b 100644
+--- a/gtweak/egowrapper.py
++++ b/gtweak/egowrapper.py
+@@ -20,9 +20,8 @@ import logging
+
+ import gi
+ gi.require_version("Soup", "2.4")
+-gi.require_version("SoupGNOME", "2.4")
+ from gi.repository import GObject
+-from gi.repository import Soup, SoupGNOME
++from gi.repository import Soup
+
+ class ExtensionsDotGnomeDotOrg(GObject.GObject):
+
+@@ -35,8 +34,7 @@ class ExtensionsDotGnomeDotOrg(GObject.GObject):
+
+ def __init__(self, shell_version_tuple):
+ GObject.GObject.__init__(self)
+- self._session = Soup.SessionAsync.new()
+- self._session.add_feature_by_type(SoupGNOME.ProxyResolverGNOME)
++ self._session = Soup.Session.new()
+
+ self._shell_version_tuple = shell_version_tuple
+ self._extensions = {}
+--
+cgit v0.12
+
diff --git a/gnome-extra/gnome-tweak-tool/gnome-tweak-tool-3.18.1-r2.ebuild b/gnome-extra/gnome-tweak-tool/gnome-tweak-tool-3.18.1-r2.ebuild
new file mode 100644
index 000000000000..46f7e0395665
--- /dev/null
+++ b/gnome-extra/gnome-tweak-tool/gnome-tweak-tool-3.18.1-r2.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils gnome2 python-r1
+
+DESCRIPTION="Tool to customize GNOME 3 options"
+HOMEPAGE="https://wiki.gnome.org/action/show/Apps/GnomeTweakTool"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+# Newer pygobject needed due upstream bug #723951
+COMMON_DEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/glib:2[dbus]
+ >=dev-python/pygobject-3.10.2:3[${PYTHON_USEDEP}]
+ >=gnome-base/gsettings-desktop-schemas-3.4
+"
+# g-s-d, gnome-desktop, gnome-shell etc. needed at runtime for the gsettings schemas
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/gnome-desktop-3.6.0.1:3=[introspection]
+ >=x11-libs/gtk+-3.12:3[introspection]
+
+ net-libs/libsoup[introspection]
+ x11-libs/libnotify[introspection]
+
+ >=gnome-base/gnome-settings-daemon-3
+ gnome-base/gnome-shell
+ >=gnome-base/nautilus-3
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40.0
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ # Add contents of Gentoo's cursor theme directory to cursor theme list
+ epatch "${FILESDIR}/${PN}-3.10.1-gentoo-cursor-themes.patch"
+
+ # Prevent problems setting WM preferences, upstream bug #706834
+ epatch "${FILESDIR}/${PN}-3.8.1-wm-preferences.patch"
+
+ # Stop relying on libsoup-gnome (from 'master')
+ epatch "${FILESDIR}/${PN}-3.18.1-libsoup.patch"
+
+ gnome2_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir gnome2_src_configure
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir gnome2_src_compile
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+ install_python() {
+ gnome2_src_install
+ python_doscript gnome-tweak-tool || die
+ }
+ python_foreach_impl run_in_build_dir install_python
+}