summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-12-14 16:33:07 +0000
committerSam James <sam@gentoo.org>2024-12-14 16:33:07 +0000
commita21d69c3cf7af7e9e4993137fc72ac1f296d6cd5 (patch)
treee93fa3e25d30bd612785195c243e00f81fcf5a2b /gnome-extra
parentapp-i18n/ibus-hangul: Fix passing argument from incompatible pointer (diff)
downloadgentoo-a21d69c3cf7af7e9e4993137fc72ac1f296d6cd5.tar.gz
gentoo-a21d69c3cf7af7e9e4993137fc72ac1f296d6cd5.tar.bz2
gentoo-a21d69c3cf7af7e9e4993137fc72ac1f296d6cd5.zip
gnome-extra/gnome-boxes: fix Modern C issues
Closes: https://bugs.gentoo.org/936516 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/gnome-boxes/files/gnome-boxes-46.1-c99.patch27
-rw-r--r--gnome-extra/gnome-boxes/gnome-boxes-46.1.ebuild4
2 files changed, 31 insertions, 0 deletions
diff --git a/gnome-extra/gnome-boxes/files/gnome-boxes-46.1-c99.patch b/gnome-extra/gnome-boxes/files/gnome-boxes-46.1-c99.patch
new file mode 100644
index 000000000000..a58797b44ece
--- /dev/null
+++ b/gnome-extra/gnome-boxes/files/gnome-boxes-46.1-c99.patch
@@ -0,0 +1,27 @@
+https://bugs.gentoo.org/936516
+https://gitlab.gnome.org/GNOME/gnome-boxes/-/merge_requests/648
+
+From 00183fd26a7b51905c179a427a38bfa18d9eb2d3 Mon Sep 17 00:00:00 2001
+From: sid <sidtosh4@gmail.com>
+Date: Wed, 22 May 2024 19:32:06 +0100
+Subject: [PATCH] libvirt-broker: Check when broker is not valid
+
+Related: #863
+--- a/src/libvirt-broker.vala
++++ b/src/libvirt-broker.vala
+@@ -24,9 +24,10 @@ public GVir.Connection get_connection (string name) {
+ return broker.connections.get (name);
+ }
+
+- public async LibvirtMachine add_domain (CollectionSource source, GVir.Connection connection, GVir.Domain domain)
+- throws GLib.Error {
+- return_val_if_fail (broker != null, null);
++ public async LibvirtMachine? add_domain (CollectionSource source, GVir.Connection connection, GVir.Domain domain)
++ throws GLib.Error {
++ if (broker == null)
++ return null;
+
+ if (pending_domains.find (domain) != null) {
+ // Already being added asychronously
+--
+GitLab
diff --git a/gnome-extra/gnome-boxes/gnome-boxes-46.1.ebuild b/gnome-extra/gnome-boxes/gnome-boxes-46.1.ebuild
index 568ae54a4ce0..e7ff1fecaa61 100644
--- a/gnome-extra/gnome-boxes/gnome-boxes-46.1.ebuild
+++ b/gnome-extra/gnome-boxes/gnome-boxes-46.1.ebuild
@@ -75,6 +75,10 @@ If you have an Intel Processor, run:
If you have an AMD Processor, run:
# modprobe kvm-amd"
+PATCHES=(
+ "${FILESDIR}"/${PN}-46.1-c99.patch
+)
+
pkg_pretend() {
linux-info_get_any_version