summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-07-02 16:07:13 -0300
committerMatt Turner <mattst88@gentoo.org>2023-07-18 18:37:45 -0400
commitcf2e836ecadd27a586ccb3ecfe067cce44eb93d3 (patch)
treef41d99418dde54b375d536fc2bb259559b9a00ed /gnome-extra
parentgnome-base/nautilus: Version bump to 45_alpha (diff)
downloadgentoo-cf2e836ecadd27a586ccb3ecfe067cce44eb93d3.tar.gz
gentoo-cf2e836ecadd27a586ccb3ecfe067cce44eb93d3.tar.bz2
gentoo-cf2e836ecadd27a586ccb3ecfe067cce44eb93d3.zip
gnome-extra/sushi: Version bump to 45_alpha2
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/31717 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra')
-rw-r--r--gnome-extra/sushi/Manifest1
-rw-r--r--gnome-extra/sushi/sushi-45_alpha2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/gnome-extra/sushi/Manifest b/gnome-extra/sushi/Manifest
index 9fc23c622888..b4862fa011a5 100644
--- a/gnome-extra/sushi/Manifest
+++ b/gnome-extra/sushi/Manifest
@@ -1,2 +1,3 @@
DIST sushi-43.0.tar.xz 81552 BLAKE2B 13ca7ec446aeaae454bb0a8c874a786914211a9b27d423189846aba9adb844b224a7f0cb6d95b2e6c4d71043a2b592d14ce9998a9732150517aa18b14b4f2c25 SHA512 0a909f685e49bbddb7fc2cf17338eba08723a796e1e42f09ed404487620437b36c2bdaede3efbb6bd49cd7efde0141e971ac9869f73c0c30bea9b6658978b19e
DIST sushi-44.2.tar.xz 82236 BLAKE2B 144b2a068c0ed81e49236ed2f43125ec9df8eb853dac6d49e55c56d489f6dd41e1704b3e22996bd80bcbda07f0843a831bdbd8296606a9688376bf7fc6140406 SHA512 0e2cd6e619872e7ebd29b01bf6038b3db7f8202f20a77034451e69b722e46ee9f8e20378253f49ccb12b6060490c25555581f10823c778c42ab9edf41016a1da
+DIST sushi-45.alpha.2.tar.xz 83288 BLAKE2B 587043020f59c1d1747393f8ad139e68764b1e98b89ad926f910f19b95504c166ec6fa340ee5a881c8643edd2c697c75843d3260cd9ac54c6cddd6e421862d02 SHA512 a5a658860731f64c00657fc34f1b494f656fb0981c10e8baf31641bbc84f6902a37853f13aab622abd40ad154a9f8e1e99e162c887e34f20f781ee33a70996ed
diff --git a/gnome-extra/sushi/sushi-45_alpha2.ebuild b/gnome-extra/sushi/sushi-45_alpha2.ebuild
new file mode 100644
index 000000000000..8c11aac1b315
--- /dev/null
+++ b/gnome-extra/sushi/sushi-45_alpha2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org meson optfeature xdg
+
+DESCRIPTION="A quick previewer for Nautilus, the GNOME file manager"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/sushi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~sparc ~x86"
+IUSE="wayland +X"
+REQUIRED_USE="|| ( wayland X )"
+
+DEPEND="
+ media-libs/libepoxy
+ >=app-text/evince-3.0[introspection]
+ media-libs/freetype:2
+ >=x11-libs/gdk-pixbuf-2.23.0[introspection]
+ >=dev-libs/glib-2.29.14:2
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ >=x11-libs/gtk+-3.13.2:3[introspection,wayland?,X?]
+ >=x11-libs/gtksourceview-4.0.3:4[introspection]
+ >=media-libs/harfbuzz-0.9.9:=
+ >=dev-libs/gobject-introspection-1.54:=
+ net-libs/webkit-gtk:4.1[introspection]
+ >=dev-libs/gjs-1.40
+"
+RDEPEND="${DEPEND}
+ >=gnome-base/nautilus-3.1.90
+ media-plugins/gst-plugins-gtk:1.0[wayland?,X?]
+"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature wayland)
+ $(meson_feature X X11)
+ -Dprofile=default
+ )
+ meson_src_configure
+}
+
+src_compile() {
+ local -x GST_PLUGIN_SYSTEM_PATH_1_0=
+ meson_src_compile
+}
+
+pkg_postinst() {
+ optfeature "Support viewing file formats such as generated by LibreOffice" \
+ app-office/libreoffice app-office/libreoffice-bin
+}