summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDee-Jay Logozzo <git@djl.id.au>2021-11-21 11:19:35 +1100
committerJoonas Niilola <juippis@gentoo.org>2021-11-29 16:15:47 +0200
commit7fbed0b1004d6bfdcf55502dcd19ff716e5d6c92 (patch)
tree40ea3c5027887e7287c07daa74055edcdeddec41 /gui-apps/tuigreet
parentmedia-libs/kcolorpicker: Drop 0.1.5 (diff)
downloadgentoo-7fbed0b1004d6bfdcf55502dcd19ff716e5d6c92.tar.gz
gentoo-7fbed0b1004d6bfdcf55502dcd19ff716e5d6c92.tar.bz2
gentoo-7fbed0b1004d6bfdcf55502dcd19ff716e5d6c92.zip
gui-apps/tuigreet: added git-live 9999 version
Changes: * Added git-live tuigreet-9999.ebuild Package-Manager: Portage-3.0.28, Repoman-3.0.3 Closes: https://github.com/gentoo/gentoo/pull/23015 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'gui-apps/tuigreet')
-rw-r--r--gui-apps/tuigreet/tuigreet-9999.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/gui-apps/tuigreet/tuigreet-9999.ebuild b/gui-apps/tuigreet/tuigreet-9999.ebuild
new file mode 100644
index 000000000000..36a65ecbb6b1
--- /dev/null
+++ b/gui-apps/tuigreet/tuigreet-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2017-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CRATES="
+"
+
+inherit cargo
+
+DESCRIPTION="TUI greeter for greetd login manager"
+HOMEPAGE="https://github.com/apognu/tuigreet"
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/apognu/${PN}"
+else
+ SRC_URI="https://github.com/apognu/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ $(cargo_crate_uris ${CRATES})"
+ KEYWORDS="~amd64 ~ppc64 ~riscv"
+fi
+
+src_unpack() {
+ if [[ "${PV}" == *9999* ]]; then
+ git-r3_src_unpack
+ cargo_live_src_unpack
+ else
+ cargo_src_unpack
+ fi
+}
+
+QA_FLAGS_IGNORED="usr/bin/tuigreet"
+
+LICENSE="Apache-2.0 Boost-1.0 GPL-3 MIT"
+SLOT="0"
+
+RDEPEND="gui-libs/greetd"