summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2024-08-24 19:37:22 +0300
committerViorel Munteanu <ceamac@gentoo.org>2024-08-24 20:06:24 +0300
commit5618ca9376b8e1f5269eec982dd36e1af053d4a2 (patch)
tree4543d224ac7ea736f5b805e55016121140a8220c /gui-libs
parentgui-apps/wcm: add 0.9.0 (diff)
downloadgentoo-5618ca9376b8e1f5269eec982dd36e1af053d4a2.tar.gz
gentoo-5618ca9376b8e1f5269eec982dd36e1af053d4a2.tar.bz2
gentoo-5618ca9376b8e1f5269eec982dd36e1af053d4a2.zip
gui-libs/wayfire-plugins-extra: add 0.9.0
Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/wayfire-plugins-extra/Manifest1
-rw-r--r--gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.9.0.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/gui-libs/wayfire-plugins-extra/Manifest b/gui-libs/wayfire-plugins-extra/Manifest
index 65a399352a88..ebc241c61a70 100644
--- a/gui-libs/wayfire-plugins-extra/Manifest
+++ b/gui-libs/wayfire-plugins-extra/Manifest
@@ -1,2 +1,3 @@
DIST wayfire-plugins-extra-0.8.0.tar.xz 70324 BLAKE2B f8f46782e31f170eb566567f50d302df4db23fbeb29c71569624a7f79c2bbcfcf48b070e7b55bf1880a9cd02afe78783d6680c457e466d765eb0db72f4b1f61b SHA512 8105fea3d8405a88d8c872c1012dadfab55f987a8ff8401f5caeec155214727021cbc7cfaba71c5ee3bc869caf136dcd78c189921c2f41a938b8552962f1597c
DIST wayfire-plugins-extra-0.8.1.tar.xz 75908 BLAKE2B 65c14281fd9738864f2d63f01250e6384cdf46929ee6df653a5614805b89686f0020799246d6caf16b8d45aa16a66f314e705ae96c37188d892d339875ed4c03 SHA512 ebe12545b0a0ca1c443f334b9bfa31d1f446636dbef2b91c280715ad58d8802ab129f6894959727c0b872558f799c973a158e679683f915a5ef89b67087eed01
+DIST wayfire-plugins-extra-0.9.0.tar.xz 104424 BLAKE2B 8dde47dd40edabb8243c6a4128229baa4d2ff3407eb9cf0ff1699ca49dfaaf16f951f4faf18138824894f94b0ca6884bbc92fab595d4e08b948b67a0a0cf054f SHA512 fb1e02c4284b499a89a8b81e2b9ef283bdde48745c5f4ee500da4d9450bc5c8d94df6b8eba5d6ff3bb05ba3edbbdbd04b3c5551a73f5765ed3406d8227177f78
diff --git a/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.9.0.ebuild b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.9.0.ebuild
new file mode 100644
index 000000000000..76b93a865547
--- /dev/null
+++ b/gui-libs/wayfire-plugins-extra/wayfire-plugins-extra-0.9.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="extra plugins for wayfire"
+HOMEPAGE="https://github.com/WayfireWM/wayfire-plugins-extra"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/WayfireWM/wayfire-plugins-extra.git"
+ SLOT="0/0.10"
+else
+ SRC_URI="https://github.com/WayfireWM/wayfire-plugins-extra/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64"
+ SLOT="0/$(ver_cut 1-2)"
+fi
+
+LICENSE="MIT"
+
+# no tests
+RESTRICT="test"
+
+WAYFIRE_REVDEP="
+ dev-libs/glib:2
+ dev-libs/libsigc++:2
+ gui-libs/wf-config:=
+ gui-libs/wlroots:=
+ x11-libs/cairo
+"
+
+DEPEND="
+ ${WAYFIRE_REVDEP}
+ dev-cpp/glibmm:2
+ dev-cpp/nlohmann_json
+ dev-libs/libevdev
+ dev-libs/wayland
+ >=gui-wm/wayfire-0.9.0
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ >=dev-libs/wayland-protocols-1.12
+ dev-util/wayland-scanner
+ virtual/pkgconfig
+"