summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris Jr. <johnmh@johnmh.me>2024-08-10 13:06:18 -0700
committerYixun Lan <dlan@gentoo.org>2024-08-11 02:41:45 +0000
commitfae9fb98ad3b44b2655af3751b58e222a2f5c237 (patch)
tree9b05b18c9bed72d3fe2561a8f1671584cee05bbe /gui-wm/hyprland
parentgui-wm/hyprland: add xcursor dep (diff)
downloadgentoo-fae9fb98ad3b44b2655af3751b58e222a2f5c237.tar.gz
gentoo-fae9fb98ad3b44b2655af3751b58e222a2f5c237.tar.bz2
gentoo-fae9fb98ad3b44b2655af3751b58e222a2f5c237.zip
gui-wm/hyprland/files: remove unused patches
Closes: https://github.com/gentoo/gentoo/pull/37930 Signed-off-by: John M. Harris Jr. <johnmh@johnmh.me> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'gui-wm/hyprland')
-rw-r--r--gui-wm/hyprland/files/bash-completion-fix-0.39.1.patch22
-rw-r--r--gui-wm/hyprland/files/wlroots-hyprland-apply-0.40.0.patch23
2 files changed, 0 insertions, 45 deletions
diff --git a/gui-wm/hyprland/files/bash-completion-fix-0.39.1.patch b/gui-wm/hyprland/files/bash-completion-fix-0.39.1.patch
deleted file mode 100644
index fe48ce45dd3a..000000000000
--- a/gui-wm/hyprland/files/bash-completion-fix-0.39.1.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-https://github.com/hyprwm/Hyprland/pull/5653
-
---- a/hyprctl/meson.build
-+++ b/hyprctl/meson.build
-@@ -2,6 +2,6 @@ executable('hyprctl', 'main.cpp',
- install: true
- )
-
--install_data('hyprctl.bash', install_dir: join_paths(get_option('datadir'), 'bash-completion'), install_tag: 'runtime', rename: 'hyprctl')
-+install_data('hyprctl.bash', install_dir: join_paths(get_option('datadir'), 'bash-completion/completions'), install_tag: 'runtime', rename: 'hyprctl')
- install_data('hyprctl.fish', install_dir: join_paths(get_option('datadir'), 'fish/vendor_completions.d'), install_tag: 'runtime')
- install_data('hyprctl.zsh', install_dir: join_paths(get_option('datadir'), 'zsh/site-functions'), install_tag: 'runtime', rename: '_hyprctl')
---- a/hyprpm/src/meson.build
-+++ b/hyprpm/src/meson.build
-@@ -9,6 +9,6 @@ executable('hyprpm', src,
- install : true
- )
-
--install_data('../hyprpm.bash', install_dir: join_paths(get_option('datadir'), 'bash-completion'), install_tag: 'runtime', rename: 'hyprpm')
-+install_data('../hyprpm.bash', install_dir: join_paths(get_option('datadir'), 'bash-completion/completions'), install_tag: 'runtime', rename: 'hyprpm')
- install_data('../hyprpm.fish', install_dir: join_paths(get_option('datadir'), 'fish/vendor_completions.d'), install_tag: 'runtime')
- install_data('../hyprpm.zsh', install_dir: join_paths(get_option('datadir'), 'zsh/site-functions'), install_tag: 'runtime', rename: '_hyprpm')
diff --git a/gui-wm/hyprland/files/wlroots-hyprland-apply-0.40.0.patch b/gui-wm/hyprland/files/wlroots-hyprland-apply-0.40.0.patch
deleted file mode 100644
index 65148b64137f..000000000000
--- a/gui-wm/hyprland/files/wlroots-hyprland-apply-0.40.0.patch
+++ /dev/null
@@ -1,23 +0,0 @@
-diff --git a/patches/apply.sh b/patches/apply.sh
-index d5492b1b..87d84848 100755
---- a/subprojects/wlroots-hyprland/patches/apply.sh
-+++ b/subprojects/wlroots-hyprland/patches/apply.sh
-@@ -4,15 +4,15 @@
- PATCHES=$(find patches/ -type f -name '*.patch')
-
- apply () {
-- git apply $PATCH
-+ patch -p1 -r /dev/null -N -s < $PATCH >/dev/null 2>&1 && echo NEW: \'$PATCH\'
- }
-
- check_applied () {
-- git apply --check --reverse -q $PATCH
-+ patch -p1 -r /dev/null --dry-run -R -s < $PATCH >/dev/null 2>&1 && echo OK: \'$PATCH\'
- }
-
- fail () {
-- echo =======\> \'$PATCH\' was not applied && exit 1
-+ echo FAILED: \'$PATCH\' NOT APPLICABLE && exit 1
- }
-
- if [ -n "$PATCHES" ];