summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-28 23:10:50 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-28 23:32:26 +0100
commit0c7ed55c2504ea2aae077eedddd170b1fa4ba696 (patch)
treebd935aacd5e845c0843c2e7038ad5c4bc8a714e7 /kde-apps/akonadi-calendar
parentkde-apps/libkgapi: Fix AccountManager promises cache handling (diff)
downloadgentoo-0c7ed55c2504ea2aae077eedddd170b1fa4ba696.tar.gz
gentoo-0c7ed55c2504ea2aae077eedddd170b1fa4ba696.tar.bz2
gentoo-0c7ed55c2504ea2aae077eedddd170b1fa4ba696.zip
kde-apps/akonadi-calendar: Convert event start time to user's local tz
Upstream commit fdbd7e42b6707cf99db48f62d43ca104de632159 KDE-bug: https://bugs.kde.org/show_bug.cgi?id=453805 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/akonadi-calendar')
-rw-r--r--kde-apps/akonadi-calendar/akonadi-calendar-22.08.3-r1.ebuild49
-rw-r--r--kde-apps/akonadi-calendar/akonadi-calendar-22.12.1-r1.ebuild49
-rw-r--r--kde-apps/akonadi-calendar/files/akonadi-calendar-22.08.3-convert-event-start-time-to-local-tz.patch33
3 files changed, 131 insertions, 0 deletions
diff --git a/kde-apps/akonadi-calendar/akonadi-calendar-22.08.3-r1.ebuild b/kde-apps/akonadi-calendar/akonadi-calendar-22.08.3-r1.ebuild
new file mode 100644
index 000000000000..d5f48f842b30
--- /dev/null
+++ b/kde-apps/akonadi-calendar/akonadi-calendar-22.08.3-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.96.0
+QTMIN=5.15.5
+inherit ecm gear.kde.org
+
+DESCRIPTION="Library for akonadi calendar integration"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-contacts-${PVCUT}:5
+ >=kde-apps/akonadi-mime-${PVCUT}:5
+ >=kde-apps/kcalutils-${PVCUT}:5
+ >=kde-apps/kidentitymanagement-${PVCUT}:5
+ >=kde-apps/kmailtransport-${PVCUT}:5
+ >=kde-apps/kmime-${PVCUT}:5
+ >=kde-frameworks/kcalendarcore-${KFMIN}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-convert-event-start-time-to-local-tz.patch" )
diff --git a/kde-apps/akonadi-calendar/akonadi-calendar-22.12.1-r1.ebuild b/kde-apps/akonadi-calendar/akonadi-calendar-22.12.1-r1.ebuild
new file mode 100644
index 000000000000..dd68fabee9f3
--- /dev/null
+++ b/kde-apps/akonadi-calendar/akonadi-calendar-22.12.1-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-3)
+KFMIN=5.101.0
+QTMIN=5.15.5
+inherit ecm gear.kde.org
+
+DESCRIPTION="Library for akonadi calendar integration"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/akonadi-${PVCUT}:5
+ >=kde-apps/akonadi-contacts-${PVCUT}:5
+ >=kde-apps/akonadi-mime-${PVCUT}:5
+ >=kde-apps/kcalutils-${PVCUT}:5
+ >=kde-apps/kidentitymanagement-${PVCUT}:5
+ >=kde-apps/kmailtransport-${PVCUT}:5
+ >=kde-apps/kmime-${PVCUT}:5
+ >=kde-frameworks/kcalendarcore-${KFMIN}:5
+ >=kde-frameworks/kcodecs-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-22.08.3-convert-event-start-time-to-local-tz.patch" )
diff --git a/kde-apps/akonadi-calendar/files/akonadi-calendar-22.08.3-convert-event-start-time-to-local-tz.patch b/kde-apps/akonadi-calendar/files/akonadi-calendar-22.08.3-convert-event-start-time-to-local-tz.patch
new file mode 100644
index 000000000000..4ede6334a029
--- /dev/null
+++ b/kde-apps/akonadi-calendar/files/akonadi-calendar-22.08.3-convert-event-start-time-to-local-tz.patch
@@ -0,0 +1,33 @@
+From fdbd7e42b6707cf99db48f62d43ca104de632159 Mon Sep 17 00:00:00 2001
+From: Kishore Gopalakrishnan <kishore96@gmail.com>
+Date: Sun, 6 Nov 2022 13:03:22 +0530
+Subject: [PATCH] Convert event start time to user's local timezone
+
+Since we don't display the timezone of the event in the notification,
+this is required when the event is in a different timezone from the
+user's local one.
+
+BUG: 453805
+
+
+(cherry picked from commit 750200aa58e3a8c4073e6304a0e214c1c5beafb9)
+---
+ reminder-daemon/alarmnotification.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/reminder-daemon/alarmnotification.cpp b/reminder-daemon/alarmnotification.cpp
+index 6082e9a..27e53e2 100644
+--- a/reminder-daemon/alarmnotification.cpp
++++ b/reminder-daemon/alarmnotification.cpp
+@@ -30,7 +30,7 @@ AlarmNotification::~AlarmNotification()
+
+ void AlarmNotification::send(KalendarAlarmClient *client, const KCalendarCore::Incidence::Ptr &incidence)
+ {
+- const QDateTime startTime = m_occurrence.isValid() ? m_occurrence : incidence->dtStart();
++ const QDateTime startTime = m_occurrence.isValid() ? m_occurrence.toLocalTime() : incidence->dtStart().toLocalTime();
+ const bool notificationExists = m_notification;
+ if (!notificationExists) {
+ m_notification = new KNotification(QStringLiteral("alarm"));
+--
+GitLab
+