summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2016-06-27 04:38:27 +1000
committerMichael Palimaka <kensington@gentoo.org>2016-06-27 04:40:29 +1000
commit515252d3151a71f7463a9c9e4a4c567a33c72c75 (patch)
tree496f222914153a86070724093aea5f9a824bad5b /kde-apps/dolphin
parentxfce-base/xfce4-settings: arm stable, bug #586614 (diff)
downloadgentoo-515252d3151a71f7463a9c9e4a4c567a33c72c75.tar.gz
gentoo-515252d3151a71f7463a9c9e4a4c567a33c72c75.tar.bz2
gentoo-515252d3151a71f7463a9c9e4a4c567a33c72c75.zip
kde-apps: version bump 16.04.2
Package-Manager: portage-2.3.0
Diffstat (limited to 'kde-apps/dolphin')
-rw-r--r--kde-apps/dolphin/Manifest1
-rw-r--r--kde-apps/dolphin/dolphin-16.04.2.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/kde-apps/dolphin/Manifest b/kde-apps/dolphin/Manifest
index fe73840f76df..039c2b6b82d7 100644
--- a/kde-apps/dolphin/Manifest
+++ b/kde-apps/dolphin/Manifest
@@ -1,3 +1,4 @@
DIST dolphin-15.12.3.tar.xz 658572 SHA256 26c347bbf65ec635162b86564c1f4693334d24afe16448f93fdacf6291d3bddd SHA512 aaad00e4ca3ccf40d66fe59de7cc0492a3e6305efa921e04445a6c35738f66a42a1618d98810e8fd811331e2cda8e5247e1f36ddbd4486cf93aa7a1ddb8a2b79 WHIRLPOOL 3d3f6fa24122a81d7a073427d8cd77d0968ced5834566a5fe2d5013fa71fd72119186963d2d72e47c1d5a31792a8b09e93557362201a017c4d76aa57e8db9507
DIST dolphin-16.04.1.tar.xz 659948 SHA256 31d90cdcdaecb384068bcaed870f3a1218df2dc4a010f851c15fb168fc28e0a5 SHA512 cbbf97662eb0a103191c8e6eb7625f498451dac01c1821a8823090c4bad6be766f50791ac71c1a63e92da5140ea16501959561ac68b08fbdd89176bba5f86790 WHIRLPOOL 35eb470641786fd16738c5784e1c29fd8880bb6a8f79758681cffeed15ce3e35e3044935b7d52c2ba5c02feda4b318e0c5c2629b9297f2a92b15c48ea78c3c7a
+DIST dolphin-16.04.2.tar.xz 660080 SHA256 621f4ae6fd586afb4f75c9b086757caec3cc75518bac065feef87f3b3b1d453b SHA512 2dae4579867cf4658e1852d57bcd4cf57ac8885b1cd6615136ac7e8e48306ccc5737ad52f10c037ac44374cb89b2d1806a2a1d0a4c3dd165d551f2059bb5ce90 WHIRLPOOL 497af8129f978c4332eac67bfda8beec4a0904130b0b542f13921308ec8d87d09e91586cb7b5859946b5f659273caf8d73519f260c6a3282e4a359ebcdaa7158
DIST kde-baseapps-4.14.3.tar.xz 2548152 SHA256 125baf42a7ab8c255b5829d12837f54c1791498f79593a9b09a9e55344ade6db SHA512 d422c1ee5cd2e1dc15b5baa2199bb85441196bc3048b9bfa443f898c3a1cfbc7f66087edf016fb594b9e48340517beef54b4429b4fde664374e75486c7cb0f9e WHIRLPOOL b22a98d140bb66ea47aeb5607e606c7a531c82787e27204f5eabb7d29d763b2bfe1456d85242d3e05e7ab4d2366fc622ef1cc624dd1954e276fb36c49840998a
diff --git a/kde-apps/dolphin/dolphin-16.04.2.ebuild b/kde-apps/dolphin/dolphin-16.04.2.ebuild
new file mode 100644
index 000000000000..589494ec509e
--- /dev/null
+++ b/kde-apps/dolphin/dolphin-16.04.2.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+KDE_HANDBOOK="forceoptional"
+KDE_TEST="true"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Plasma filemanager focusing on usability"
+HOMEPAGE="https://dolphin.kde.org https://www.kde.org/applications/system/dolphin"
+KEYWORDS="~amd64 ~x86"
+IUSE="semantic-desktop thumbnail"
+
+DEPEND="
+ $(add_frameworks_dep kbookmarks)
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kcrash)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kinit)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kparts)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ $(add_frameworks_dep solid)
+ $(add_qt_dep qtconcurrent)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ media-libs/phonon[qt5]
+ semantic-desktop? (
+ $(add_frameworks_dep baloo)
+ $(add_frameworks_dep kfilemetadata)
+ $(add_kdeapps_dep baloo-widgets)
+ )
+ !semantic-desktop? (
+ $(add_frameworks_dep kdelibs4support)
+ )
+"
+RDEPEND="${DEPEND}
+ $(add_kdeapps_dep kio-extras)
+ thumbnail? (
+ || ( $(add_kdeapps_dep ffmpegthumbs) media-video/ffmpegthumbnailer )
+ $(add_kdeapps_dep thumbnailers)
+ )
+"
+
+RESTRICT="test"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package semantic-desktop KF5Baloo)
+ $(cmake-utils_use_find_package semantic-desktop KF5BalooWidgets)
+ $(cmake-utils_use_find_package semantic-desktop KF5FileMetaData)
+ )
+
+ kde5_src_configure
+}
+
+pkg_postinst() {
+ kde5_pkg_postinst
+
+ if ! has_version "kde-apps/ark:${SLOT}" ; then
+ echo
+ elog "For compress/extract and other actions, please install kde-apps/ark:${SLOT}"
+ echo
+ fi
+
+ if ! has_version "kde-apps/kleopatra:${SLOT}" ; then
+ echo
+ elog "For crypto actions, please install kde-apps/kleopatra:${SLOT}"
+ echo
+ fi
+}