summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-10 09:30:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-10 16:50:00 +0100
commitf1b6a4697cb6bd8b01b005cca0996982fd736a2d (patch)
tree9b2799b0df1355e0ee40b8c909752698a0803837 /kde-apps/pimcommon
parentapp-emulation/libvirt: init submodules for live ebuild (diff)
downloadgentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.tar.gz
gentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.tar.bz2
gentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.zip
kde-apps: Add KDE Applications 18.12.1
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/pimcommon')
-rw-r--r--kde-apps/pimcommon/Manifest1
-rw-r--r--kde-apps/pimcommon/pimcommon-18.12.1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/kde-apps/pimcommon/Manifest b/kde-apps/pimcommon/Manifest
index 386a3882f2f0..312ba21c751f 100644
--- a/kde-apps/pimcommon/Manifest
+++ b/kde-apps/pimcommon/Manifest
@@ -1,2 +1,3 @@
DIST pimcommon-18.08.3.tar.xz 292804 BLAKE2B ca220c53168fec1dc89fbc640c13becf96b7115fa36175d46b2457a63beedeb30d858e450c9d86e121ebd8e19b1aa932cf468bb62b7957c69319b64b1e409141 SHA512 212862d77d596d7f94a6685f2fdd50d08f26330933ec601e2b8bf1f1f2077e142f55836b8294b2513bf735a18fb21070e078af034056254a4ed65245c1f217fb
DIST pimcommon-18.12.0.tar.xz 294900 BLAKE2B 7ce13668a4249f51c6b2724d2296de7326a1c221e2ffec19833a879b467cfeac0c8cd75a5531a119ecea0b98909dea0464491927efdcdf0644aaffaedb68193b SHA512 212d1d9e46e834dfa78d780bff0a39452960d98e2bb52743b512c62c15babec25adaae06b57d0c00b02fd7e35ce16090ae5594e2ecaf54b3093a2ba6efd1cf71
+DIST pimcommon-18.12.1.tar.xz 295008 BLAKE2B 8ef2853767e3e87723a014282491b38eb2a88ad340726039efc856688517cf89fd9aec67bdc45ead8d6c0a45c61425ef80685cb62bd56f41a29724719412b871 SHA512 b1da041475e004ff1a9124b8b6d3c2dd403f1e4b7f988451aeeb8a970cb64b3486a9f3c0ed11ef87790eb40e74cb6e2648e0590c1e458a8c23093fa1edfd35e5
diff --git a/kde-apps/pimcommon/pimcommon-18.12.1.ebuild b/kde-apps/pimcommon/pimcommon-18.12.1.ebuild
new file mode 100644
index 000000000000..81d7c122d367
--- /dev/null
+++ b/kde-apps/pimcommon/pimcommon-18.12.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_DESIGNERPLUGIN="true"
+KDE_TEST="forceoptional"
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Common PIM libraries"
+LICENSE="GPL-2+ LGPL-2.1+"
+KEYWORDS="~amd64 ~x86"
+IUSE="share"
+
+COMMON_DEPEND="
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kitemmodels)
+ $(add_frameworks_dep kjobwidgets)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kxmlgui)
+ $(add_kdeapps_dep akonadi)
+ $(add_kdeapps_dep akonadi-contacts)
+ $(add_kdeapps_dep kcontacts)
+ $(add_kdeapps_dep kimap)
+ $(add_kdeapps_dep kpimtextedit)
+ $(add_kdeapps_dep libkdepim)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtwidgets)
+ $(add_qt_dep qtxml)
+ dev-libs/grantlee:5
+ share? ( $(add_frameworks_dep purpose) )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kiconthemes)
+ dev-libs/libxslt
+ test? ( $(add_kdeapps_dep kmime) )
+"
+RDEPEND="${COMMON_DEPEND}
+ !kde-apps/kdepim-common-libs:4
+ !kde-apps/kdepim-l10n
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package share KF5Purpose)
+ )
+
+ kde5_src_configure
+}
+
+src_test() {
+ # bugs 641730, 661330
+ local myctestargs=(
+ -E "(autocorrectiontest|pimcommon-translator-translatortest)"
+ )
+
+ kde5_src_test
+}