summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-03-08 19:04:08 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-03-08 19:04:39 +0100
commitd7443e05892e21953f2476002a87f3c0213706bb (patch)
treebdc943e4106bc2c6f20218650cf96563b88f1827 /kde-apps/print-manager
parentsys-fs/zfs: drop old (diff)
downloadgentoo-d7443e05892e21953f2476002a87f3c0213706bb.tar.gz
gentoo-d7443e05892e21953f2476002a87f3c0213706bb.tar.bz2
gentoo-d7443e05892e21953f2476002a87f3c0213706bb.zip
kde-apps: Add KDE Applications 17.12.3
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'kde-apps/print-manager')
-rw-r--r--kde-apps/print-manager/Manifest1
-rw-r--r--kde-apps/print-manager/print-manager-17.12.3.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/kde-apps/print-manager/Manifest b/kde-apps/print-manager/Manifest
index 12415cb08f44..8b830669441e 100644
--- a/kde-apps/print-manager/Manifest
+++ b/kde-apps/print-manager/Manifest
@@ -1,2 +1,3 @@
DIST print-manager-17.08.3.tar.xz 237084 BLAKE2B c85e6fb2e41cd2264fe33af6585363bea85bee57a8c42f85da6ed3a0b4972c8d1647dd4e4b10e42f8c0ba98ce9c7e93efbf90a938396341dac04782ca1272a2a SHA512 cb09762fc736a88c41850593b8c0d3ff1eb0f3308653a93ee1b370dd8a4b7d13de64fcea3b76f7407f430faf5d5cc2cc5a2a3c58dbd80f4c076af4a60788181c
DIST print-manager-17.12.2.tar.xz 237132 BLAKE2B 3b4169d5974f634eafdf6d5c8e3c90fd66f8248fa61dd71e77d21969987af54fe06f17d032dde463d93b8d23205e46fb5d85b1fa0cb17cbb967a025d3f8e672c SHA512 82e99d595c2e00e6d1f5f481039bd5482310002ac7851bd3d682e19e4a49432165a443d8614e026b83536543e55068ba0d15679ef0aa110223285536e62aa339
+DIST print-manager-17.12.3.tar.xz 237128 BLAKE2B cc1a85c6ed2f160329c5428de7c6de562de7f5c3876fdd504e619801e8ededd792c8b69c9193a787d1600948f7fae3a62a7290e1e50ea5bf39475d9db9c9c66c SHA512 80e40c913da002beb3e473e0e6fa6f02b0e3b699bdc49c390435d9139f46b1fb3ffef54c042b5dc2a1db3b83da2f4f53377710b31281b0154f9654f605b95830
diff --git a/kde-apps/print-manager/print-manager-17.12.3.ebuild b/kde-apps/print-manager/print-manager-17.12.3.ebuild
new file mode 100644
index 000000000000..e59f9d37adbc
--- /dev/null
+++ b/kde-apps/print-manager/print-manager-17.12.3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit kde5
+
+DESCRIPTION="Manage print jobs and printers in Plasma"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gtk"
+
+DEPEND="
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdbusaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep plasma)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtdeclarative)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ net-print/cups
+"
+RDEPEND="${DEPEND}
+ $(add_plasma_dep kde-cli-tools)
+ gtk? ( app-admin/system-config-printer )
+"
+
+pkg_postinst(){
+ if ! use gtk ; then
+ ewarn
+ ewarn "By switching off \"gtk\" USE flag, you have chosen to do without"
+ ewarn "an important, though optional, runtime dependency:"
+ ewarn
+ ewarn "app-admin/system-config-printer"
+ ewarn
+ ewarn "${PN} will work nevertheless, but is going to be less comfortable"
+ ewarn "and will show the following error status during runtime:"
+ ewarn
+ ewarn "\"Failed to group devices: 'The name org.fedoraproject.Config.Printing"
+ ewarn "was not provided by any .service files'\""
+ ewarn
+ fi
+}