summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2017-06-12 20:49:22 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2017-06-12 20:49:22 +0200
commit40be27c1a70a5a91aed40b9ba72ffada8f181455 (patch)
tree8ebe11f07b05fabc128a918faf00bd0a2e2ab403 /kde-frameworks/frameworkintegration
parentxfce-base/garcon: Add missing desc for gtk2 flag (diff)
downloadgentoo-40be27c1a70a5a91aed40b9ba72ffada8f181455.tar.gz
gentoo-40be27c1a70a5a91aed40b9ba72ffada8f181455.tar.bz2
gentoo-40be27c1a70a5a91aed40b9ba72ffada8f181455.zip
kde-frameworks: Add KDE Frameworks 5.35.0
Package-Manager: Portage-2.3.5, Repoman-2.3.1
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.35.0.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 3bba744e5e1a..3f1cd264f78f 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1 +1,2 @@
DIST frameworkintegration-5.34.0.tar.xz 1751972 SHA256 40ac4623c0292442853ac8e905c0282aaa0063c594693beae7c07f69bfc80143 SHA512 ccb9b954471ad423c72f7bc7db5034f902120df78b7b6a48689ea55631bf0c7396a2b06862fa84106212bee470bb2b6f072d2182904c1720d27a1f943fa07bc7 WHIRLPOOL 7a18565103098f63522d0b5b7d9a343c1f5ee2b3526ab8b353943696fe00680afd1433582ea718fae0ee6ee732d898cdb56985ab481575634e751b5add7b3b83
+DIST frameworkintegration-5.35.0.tar.xz 1752016 SHA256 2f4d0433d1243abf62369b3d1a3170667dbfe2afe799bce7e4959c03b9b8d983 SHA512 1c421573618ee5deb78e2f67e96af94bd1950b2869b4e3972a169835cc8a461bc5061afda311e600482e3980f3412328b2fac83f86f7d12090ca9d5fb71eecec WHIRLPOOL 2ae0d00076a9dd2339249a171c1a9a477efc48c8f032bc25b054701d8b554f9fc876ebed3d54b6699fe6e9e216966a779676e1a6a3c276c50ead49dfd90730fe
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.35.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.35.0.ebuild
new file mode 100644
index 000000000000..736635e23d9f
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.35.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+VIRTUALX_REQUIRED="test"
+inherit kde5
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="appstream X"
+
+RDEPEND="
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep knewstuff)
+ $(add_frameworks_dep knotifications)
+ $(add_frameworks_dep kpackage)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ appstream? (
+ app-admin/packagekit-qt
+ dev-libs/appstream[qt5]
+ )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb
+ )
+"
+DEPEND="${RDEPEND}"
+
+# requires running kde environment
+RESTRICT+=" test"
+
+src_prepare() {
+ punt_bogus_dep Qt5 DBus
+ kde5_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package appstream AppStreamQt)
+ $(cmake-utils_use_find_package appstream packagekitqt5)
+ $(cmake-utils_use_find_package X XCB)
+ )
+
+ kde5_src_configure
+}